Cabbage Logo
Back to Cabbage Site

Cabbage build for Mac with multi outputs?

Yeah, you can just rename Cabbage.app to something else, then install the new one. It was no trouble at all.

I cannot find the cabbage.app file within the package contents. Where might it be?

Sorry, you should rename the Cabbage.app package in your applications folder…

As in rename the Cabbage Application, like this?

That’ll do the trick.

Cool thanks. Was just making sure that was the correct item to rename. I’ll blast away at it. Have a nice day!:slight_smile:

You might be back sooner than you think, I didn’t test this packge at all!!

Yup, I’m back :wink:

Cabbage crashes if any more than 2 output channels are named. Also, there is no option in audio settings to chose more than 2 channels at one time. I guess this does not matter as you said the standalone won’t have multichannel connectivity.

The standalone doesn’t have any multichannel capabilities, so that’s expected. I just checked here with the new package I built and I’m getting the same issue as you. I’ll take a look now.

I can’t get this to work at the moment. I’m not sure what I changed, but my previous hacks are no longer working. If you bear with me I should have support for multi-channel in the new Cabbage. Maybe within 2 weeks? But with the new system you’ll be able to use both the standalone and plugins in full multichannel mode. If you’re stuck for it, or it’s preventing you from moving forward let me know and I will put some time aside to resolve it. Cheers.

Okay. Don’t want to put further work on you. Maybe if you have any beta multichannel versions in the meantime you could send them on and I’ll test them out?

That’s exactly what I’m going to try to do. Just working on it now.

Ok. Try this out. It’s a 64 channel plugin built with the new version of Cabbage. You’ll have to work with this manually for the time being until I add export options to the new standalone host. This plugin should work out of the bag. Just extract and drop it onto an audio track. You should see 8 channels of diminishing gain.

In order to use your own instruments, simply paste your code into the CabbagePlugin.csd file that’s contained within this .vst bundle. This is the file the plugin opens when instantiated. It’s a bit messy I know, but at least it gives you something for the weekend :wink:

nchnls sets the number of channels that will be processed by the plugin. Most hosts I know of will ask the user for the amount of channels they wish to use, and limit processing to that amount. Any host that tries to process all 64 channels will get silence on any channels that are above the nchnls count. I still have to do some profiling on this, and run tests on as many hosts as I can, but I think this might be the way to go.

p.s. by 64 channels might be overkill…maybe 32 would suffice?

Thanks Rory! I am indeed getting multichannel output using Reaper.

But the emerging audio is badly mangled/bitcrushed.

I am using the same sample rate in Reaper as I am in the plugin, 44100.

My code looks like this:

I’ve tried in Ableton also. I can’t test the multichannel due to Ableton’s stereo limitation per track, but the audio is also mangled by the plugin.

Hmm. I’ll take a look.

Looks like the in opcode is causing the problem. Can you try inch instead? I just updated the plugin zip with the very latest one I built here. It’s 16 channels instead of 64. But that is probably the only difference. I don’t think I changed anything else. Let me know. I’ll be away from my mac until Monday, so I’ll keep my fingers crossed this works!

Yes, “inch” seems to do the trick. Many thanks, Rory!

Hi again, Rory. I was wondering if any progress has been made on the multichannel standalone version of Cabbage? Cheers! Martin

It still needs a little work, but it’s almost there. To be honest, I can’t recall if it is already available in the current beta version of Cabbage 2 for OSX. It may well be as I rarely ever use it. But I can check again when I get back to Ireland early next week.