Cabbage Logo
Back to Cabbage Site

Fmod doesn't recognize plugin

And I assume it still doesn’t work? I’m going to try now myself on a fresh Window 10 machine…

1 Like

Are ytou sure your plugin dll and .csd file are in the folder you’ve set to be the plugins folder? I just did an install of both Cabbage and FMOD on a fresh Windows 10 machine and I had no issues, as you can see in the pictures below. Excuse the cropping at the top, but you can see I exported a simple example, set my plugins folder in FMOD, and then insert the plugin into the event track.

Thanks for taking the time
This is how I have set it up…

Can you open the command prompt, navigate to the desktop folder, and run the dir command?

[edit] I ask because I can’t say for certain if they are the same directories from the information you’ve provided…

Looks Ok to me. Can you post the two .csd files? If you don’t want others to view them you can PM me instead.

I’ve used examples to test it.

Plug1.csd (6.6 KB)

test.csd (19.7 KB)

Can you try one of these examples:


Note that you can design instruments with Cabbage, but the Cabbage examples will need some editing in order to get them to work in FMOD. However, I think they should still show up. Try one of these and let me know if it works.

I tried the bells.csd and while it worked fine inside cabbage, when I exported it, it didn’t show up.
If you could export it in your windows pc, I could test the .dll in my fmodstudio to see where the trouble starts.

Good idea. Here you go:

I didn’t have a chance to test the plugins earlier, but I’m on my home machine now, and I can confirm that this plugin loads and runs fine…

Unfortunately it doesn’t show up. I installed a fresh version of fmod studio and it didn’t help.

Does the FMOD Console window print anything of note? I also just did a fresh install of FMOD. And it works fine where. Hmm. Any other ideas? Can you try putting the fmod plugin folder somewhere else? Perhaps there are permission issues with your desktop folder. Try somewhere in “My Documents” perhaps.

The console prints:
20:15:07 fmod_os_misc.cpp(784), FMOD_OS_Library_Load(): LoadLibrary failed to open ‘D:/FMODPlugs/bells.dll’, GetLastError = 126 [#2 times]
20:15:07 Error loading plugin D:/FMODPlugs/bells.dll: File not found.

so there is that.
Moving the folder to My Documents didn’t work.
I could try to get another third party plugin to see if that shows up. At least we could find out for sure that it is fmod’s issue. Can you recommend any plugin I could test?

I haven’t actually used FMOD is quite some time, so I don’t know of any 3rd party plugins. But it would be good to test one as see. Let me know. Something very strange is happening, but I can’t tell what it is.

Hi rory! I was trying to do one of my subject’s work, based on putting sound with a new created plugin using fmod and cabbage for it. I have the same problem as the guy in this forum. I’ve followed all the stages of your explanation, but i cant fix the problem. As you didnt keep on talking about the problem, i cant find any way to fix it. Could you help me please?? It’s very important to pass the subject in 2 months!!

I didn’t reply again because I was waiting for confirmation on whether other 3rd party plugins work. As I mentioned above, it works ok for me. The question is, how can I fix a problem that I can’t create? Can you confirm that other 3rd party plugins work for you. Are you also using Windows?

Hey,
Sorry for not replying earlier.
I didn’t manage to find any other 3rd party plugins so I put it on hold and have been setting up another system on my mac to work side by side with the windows one. FMOD studio on mac also crashes when loading cabbage plugins but I need to test it more.
I asked the question on the FMOD forum, however, and they referred me back here (my other post).

I will check in my Mac tomorrow and let you know. It would be great in fact if I can recreate the problem there. Might help me find a fix that will work on Windows.

Hey,
All plugins that i’ve tested dont appear in fmod “Add plugin Instrument”. We are 2 guys trying to add plugins in our respective Windows OS, but we have the same problem.

Do non Cabbage plugins work?