Cabbage Logo
Back to Cabbage Site

Dropouts in 2.7.13

Great that you could test it! But strange with my system. I had the older vst already exported before and now I tried again reverting to 2.7.13 from July 30 - back to no dropouts.

My system is MacBook Pro (Retina, 15-inch, Mid 2015) with macOS 10.14.6.

… and there is also the thing with init of the S/L (Save/Load) buttons in my plugin. The preset gets loaded at init with the later beta. I can prevent that but something else is different between the two betas other then the obvious upgrades that you did.

I’ll trigger a new build with the live specific changes removed for you to try. At least it will rule that out or not. My Mac is 2013, high Sierra. Have to put the kids to bed first though :stuck_out_tongue_winking_eye:

Btw, it all works fine in other hosts?

Thanks! I’ll try in Garage band - the only other DAW I have available at the moment. Btw. if the vst file name has a dot in it, I get this tiny GUI - I think you told me that it has to do with parsing the file extension

I just made an AU and no dropouts there - in Ableton! Also no issues in GB. I have only tested with VST. Have you tried VST?
I had problems with AU in the past related to automation, so I kind of dismissed it, but I might find other issues with AU now :wink:

I’ve only been testing with vst 2.4. do you have Reaper installed?

New pests:
(1) AU doesn’t seem to broadcast internal chnset - a ghost from the past.
(2) AU has the same problem with recording automation as you fixed for VST - you have only one shot to record it, the next time around it doesn’t do it anymore.

These issues are soooo frustrating making plugins unusable as plugins.

I have no other DAWs to test with at the moment. I could install Reaper perhaps…

Are you running these AU tests with Live or GB?

Your plugin works without any issues for me, as the screen-grab showed. So, your plugin is completely and utterly 100% usable as a plugin here, with automation in both Live 9 and Live 10. I hope we get to the route of what’s causing the issues on your machine.

No dropouts in Reaper. I never used Reaper, so I’ll get a test run on it these coming days. Great news that it works on your system. Thanks for testing! It seems I might need to do some upgrading - which really annoys me. But I don’t know if there are any other options?

Automation recording test in Live.

This is not the fist time I’ve been blindsided by Live. I’m going to try the AU version there now and see if I can recreate the automation issue. I wouldn’t be upgrading my machine just yet. I’ms till on 10.16.3. I’m going to trigger a build now without that recent Live changes. Test it and let me know if you no longer get dropouts.


I’ll need to slowly put myself to bed, so I’ll get back tomorrow!

This is not the case here. I just tested the latest version and everything works as I would expect with the AU version. This is mind boggling. I can’t understand why you are hitting these issues. :thinking:

p.s. That build is triggered and clearly marked so you can find it again tomorrow, even if I push another update in the meantime.

I tried now with the marked build. Dropouts are gone in both vst and au. There is some minimal dropouts when I change presets with vst but not au, but I think this is no problem, there are some differences between au and vst though.

Importantly, sliders are not automatable now, well most of them except some random ones (different for au and vst). For reference I tested also the previously exported plugins with results consistent to what I saw previously. In ref, to the last video you posted, could you try changing slider with the buttons (x2, /2)?

I’ll try it also in Reaper this evening, after I learn how to handle automation there.

Sliders are not working because I reverted the “fix”. This build is broken. I just wanted to see if the dropouts are gone. So we now know, without any doubt, that the automation fix was causing the problem. Back to the drawing board then. I’ll try some other things.

Btw, I tested with the new and old versions and automation in Reaper works just fine. This is clearly an issue with Live.

I’l try that now. I was checking the cabbageSet stuff for automation.

CHNSET_GESTURES are back :rofl, only I’ve renamed them to CSOUND_GESTURES. Check the announcements thread. I’m still looking into the other issues.

You did it again - my favourite wizard! :slight_smile:
No more dropouts. There is still a small difference, where vst has some glitches when changing presets (reading from table) and au doesn’t.
Now I need to get the CSOUND_GESTURES to work in my favour. I am curious though what you did and if automation was indeed causing troubles?

My first fix was to wrap every slider changes with a being and end gesture call. This was overkill, and although it worked fine for me here, I suspected it was causing the dropouts for you. So now I make sure to grab the last value from the slider in the sliderEndDrag() method before calling gesture end. This is not needed for any other DAW, but it’s also not going to cause any problems for them either.

Thanks for the info! I’m not much wiser but it helps to get a feel what you’re doing.