Cabbage Logo
Back to Cabbage Site

String feedback example xruns on Linux


I’m only getting xruns and no sound running the string feedback example on Linux, using Jack, no matter how high I set the Frames/Period and Periods/Buffer. No sound also on ALSA.

On an unrelated note, I’m using a tiling window manager (awesome wm) and JUCE does some really weird things (for example the examples button is unusable after the first time you click it).
The first time I compiled it (I don’t remember which version), the window didn’t even show anything.

I built from the lastest develop branch, using

./buildCabbage “/usr/local/include/csound/” “/usr/local/lib/csound/” “/home/me/VST3/”

it failed with:

In file included from …/…/JuceLibraryCode/modules/juce_audio_processors/juce_audio_processors.cpp:152:0:
…/…/JuceLibraryCode/modules/juce_audio_processors/format_types/juce_VSTPluginFormat.cpp:49:44: fatal error: pluginterfaces/vst2.x/aeffectx.h: No such file or directory
#include “pluginterfaces/vst2.x/aeffectx.h”

It seems that it doesn’t find the VST directory even though I have it:

ls -l ~/VST3/pluginterfaces/vst2/aeffectx.h
-rw-r–r-- 1 me me 65211 Nov 12 16:10 /home/me/VST3/pluginterfaces/vst2.x/aeffectx.h

However it seems that it compiles anyways, I tried it and the string feedback example works!

The JUCE issues with my window manager are still prevalent though

JUCE seems to have an issue with different windows managers on Linux. What windows manager did you say you were using?

awesome wm

The main problem is that after opening an example the examples dropdown doesn’t work, so you have to restart cabbage to try another example, the other dropdowns seem to work though.

I’ll have a look through the JUCE forums and see if anyone has had an similar problems. But this looks like a JUCE/Linux problem rather than a Cabbage specific one. Anyhow, I’m glad you got the string feedback example to work. It’s great!

It most likely is a JUCE problem. Those kind of bugs happen quite frequently with more “alternative” gui toolkits using tiling window managers.

I found something about nativeFileChooser but it seems this is not the problem (and you already have an option for that)
I’ll look a bit more.

Any ideas why it’s not finding the VST files? I don’t need it right now but I may want to create a VST in the future.

The string feedback example is indeed pretty nice.

Can you try passing the complete full path for the VST3 sdk?

He seems to be passing the full path, isn’t he? As a workaround he could copy “pluginterfaces/vst2/*” (dir, sub-dir and headers) into “JuceLibraryCode/modules/juce_audio_processors/format_types/”. I remember doing that to solve the problem in old versions.

I never heard of that one before, but worth a try I guess. Sorry, you’re right, he is passing the full path. I need to download the vst3 sdk and get this sorted. I’m still using the 2.4 one!

It’s interesting that this example was being discussed. I tried it out, using the most recent build on both Windows and Mac, and found it to be non-working on both!

After some fiddling around I traced the problem to this line in instr 1:

 krefl	=	1-ksustain		; string damping (derived from sustain value). Higher values = more damping. Range 0 - 1

Simply commenting out this line and retyping:

krefl = 1-ksustain

fixed the problem on both platforms so I assumed it must be some parsing quirk involving tabs or a hidden character, but even after further fiddling I haven’t been able to pinpoint what it was. Paranormal intervention probably.
(On Windows there is also our friend the linsegr bug but is easily worked-around and will hopefully be gone altogether shortly.)
I’ll keep looking into this and try and find out exactly what it was, but I thought I’d mention it in case you have any ideas.

Works here with the latest version on Windows? Uploaded lalst night. v1.0.04
I did recently fix a silly bug that causing some parsing issue. It was something I introduced a while back, but didn’t pop u often. Anyhow, it’s gone now and this example runs fine for me. I will try to get an OSX update out soon.

Sorry, how do I get v1.0.04? The Windows version on the main site (64 bit) is v1.0.00 and seems to exhibit the problem.

Of course it’s there, thanks. I was just thinking that maybe a parsing error fix should be pushed to the official release as soon as possible, but perhaps there are other issues with the beta version that prevent that. I was just thinking back to a new-user comment on the main Csound list recently, saying that he was almost put off sticking with Csound on account of seg. faults. Non-working examples in the official release might present a similar problem.

Should the betas be published in the Downloads page also? In the long run, are we going to see Stable/Unstable releases?

I would like to roll out a new release as soon as possible, but the hold up with Csound6.07 is what’s preventing this from happening. As soon as it is released I’ll have to update all the packages. But, I do realise that we have tested about 4 minor releases since the last official release, so it’s high time that we got one out.

I have got through most of the outstanding bugs, so perhaps I will just go ahead over the next few days and create a release. OSX and Linux are not a problem. I’ll test Mike’s Windows package again in the next few days and see if everything is compatible with the latest Cabbage. If it is, then maybe I’ll just go for it.

But wouldn’t we need a stable version for this to happen! :wink: I might add a link to the sticky on the forum from the main page. At least users can go there and try the latest packages if they do find a problem.

Under Linux, Cabbage is pretty stable in my opinion. Most of the time the bugs (the ones that force you to restart or at least reload the instrument) seem to be in the editor. Windows is a different thing. With v1.0 you sometimes open an instrument and “Cabbage has stopped working…” or something like that. You open it again and it works. ¯_(ツ)_/¯

It seems far better now than it was back in v1.0.0. But I agree, Windows needs more love!