Cabbage Logo
Back to Cabbage Site

Cabbage build for Mac with multi outputs?

Yup, I’m back :wink:

Cabbage crashes if any more than 2 output channels are named. Also, there is no option in audio settings to chose more than 2 channels at one time. I guess this does not matter as you said the standalone won’t have multichannel connectivity.

The standalone doesn’t have any multichannel capabilities, so that’s expected. I just checked here with the new package I built and I’m getting the same issue as you. I’ll take a look now.

I can’t get this to work at the moment. I’m not sure what I changed, but my previous hacks are no longer working. If you bear with me I should have support for multi-channel in the new Cabbage. Maybe within 2 weeks? But with the new system you’ll be able to use both the standalone and plugins in full multichannel mode. If you’re stuck for it, or it’s preventing you from moving forward let me know and I will put some time aside to resolve it. Cheers.

Okay. Don’t want to put further work on you. Maybe if you have any beta multichannel versions in the meantime you could send them on and I’ll test them out?

That’s exactly what I’m going to try to do. Just working on it now.

Ok. Try this out. It’s a 64 channel plugin built with the new version of Cabbage. You’ll have to work with this manually for the time being until I add export options to the new standalone host. This plugin should work out of the bag. Just extract and drop it onto an audio track. You should see 8 channels of diminishing gain.

In order to use your own instruments, simply paste your code into the CabbagePlugin.csd file that’s contained within this .vst bundle. This is the file the plugin opens when instantiated. It’s a bit messy I know, but at least it gives you something for the weekend :wink:

nchnls sets the number of channels that will be processed by the plugin. Most hosts I know of will ask the user for the amount of channels they wish to use, and limit processing to that amount. Any host that tries to process all 64 channels will get silence on any channels that are above the nchnls count. I still have to do some profiling on this, and run tests on as many hosts as I can, but I think this might be the way to go.

p.s. by 64 channels might be overkill…maybe 32 would suffice?

Thanks Rory! I am indeed getting multichannel output using Reaper.

But the emerging audio is badly mangled/bitcrushed.

I am using the same sample rate in Reaper as I am in the plugin, 44100.

My code looks like this:

I’ve tried in Ableton also. I can’t test the multichannel due to Ableton’s stereo limitation per track, but the audio is also mangled by the plugin.

Hmm. I’ll take a look.

Looks like the in opcode is causing the problem. Can you try inch instead? I just updated the plugin zip with the very latest one I built here. It’s 16 channels instead of 64. But that is probably the only difference. I don’t think I changed anything else. Let me know. I’ll be away from my mac until Monday, so I’ll keep my fingers crossed this works!

Yes, “inch” seems to do the trick. Many thanks, Rory!

Hi again, Rory. I was wondering if any progress has been made on the multichannel standalone version of Cabbage? Cheers! Martin

It still needs a little work, but it’s almost there. To be honest, I can’t recall if it is already available in the current beta version of Cabbage 2 for OSX. It may well be as I rarely ever use it. But I can check again when I get back to Ireland early next week.

Thanks, Rory :slight_smile:

The last method you suggested (opening multichannel VST’s) works okay, but it does not seem to permit running more than one Cabbage multichannel VST at a time. If I try to duplicate the template VST you sent me; rename it and input new Csound code to try and make a second VST, afterwards, only the original VST shows up within the DAW.

I assume this is the link to the thread on that beta version here?

I’m just testing it out. I’ll let you know.



The first approach will not work for multiple plugins because the IDs are the same. you would need to edit the plist file that’s contained within. But maybe the current plugs work. If not it should be easy to enable them.

Ah yes, I had changed everything bar the plist. I hadn’t really needed to use two different plugins at a time anyways, but was considering it now that the standalone I was using for a project has become too CPU heavy.

I’ve been experimenting with the beta release and I seem to be getting at least 8 channels of audio out :slight_smile:

I have tried changing the name and I also changed it everywhere it appears in the plist file and no joy as yet. Only the older plugin still shows up when I search for the VST within my DAW. Maybe I going about it wrong.

The current plugs only seem to export as stereo (I made sure the 8 patch chords I needed were connected in the beta version of Cabbage, and I saved each as a Cabbage patch before exporting). Did you mean in the last message that there was a way of “enabling” them?

Sorry to be a pain!


You probably need to modify the binary data too which is a pain. Cabbage does that when it exports the plugins. Have you tried replacing the effect plugins in the standalone with the multi plugin that works? Cabbage should be able to export it ok then?

Cheers, Rory. Having some kind of success with your your second method.

This version of Cabbage seems to crash on loading some heavier (lots of granular type stuff) plugins that worked in the previous version, but I love the look, smoother scrolling and the ability to jump to different sections/instruments using the drop down menu.

If you can send me the .csd that would be helpful. Or if you would rather not share them in public just PM me.