Cabbage Logo
Back to Cabbage Site

Cabbage can't execute csd with space in path or file name


Recently I I’ve been gradually changing my main Csound front end from Csound QT to Cabbage because of its nice widgets. I’m very happy with Cabbage, but I’d like to point out a few things that could be updated in the future.

Cabbage can’t execute csd file if the path or file name contains space. I know it’s a standard in code development to avoid space in path or file name. However, it will be very useful If this restriction is removed.
Multi byte characters are also not allowed in path/file name. I hope this will be solved too.

Multibyte characters area an issue, but I’ve problems opening files with whitespaces? What version of Cabbage are you using?

btw. welcome to the forum!

Hi Rory,
I use Cabbage 2.6 on MacOS11.4(Intel MacBook Pro).
I can open the csd with whitespace in its path and/or file name, but Cabbage does not respond to ‘Play’ button.

Thanks, I’ll take a look. Although I’m not a fan of whitespaces, I think they should be supported :+1:

I just tested here with whitespaces, and it loads and runs fine? Can you provide me with the path and file name you are using so I can test here with the same?

test 1.csd (579 Bytes)

The path is /Users/tetsuya/Desktop.

I guess that the language setting might be responsible for this issue and tested with different settings in System Preferences. The result below is confusing… Not sure if this issue really relates to language setting.

Seq#1 Preferred language=Japanese, open csd on Cabbage => Csd can’t be run
Seq#2 Preferred language=English, restart PC, open csd on Cabbage => Csd can be run
Seq#3 Preferred language=Japanese, restart PC, open csd on Cabbage => Csd can be run(!)
Seq#3 Quit Cabbage, launch Cabbage again and open csd => Csd can’t be run(!!)

Further testing(Preferred language=Japanese, tested 2 times):
If I open the csd in Cabbage which is launched first time after PC restart, the CSD can be run.
However, once I quit Cabbage and launch again and open the csd, it can’t be run : After clicking ‘Play’ button, no message appears in the console and no sound output. Clicking ‘Stop’ button does not work(the button does not return to ‘Play’)

I’m not sure how best I can test this here. When I add non ascii characters to a path, Cabbage can still read the path and load and run the file without issue? The path you posted above contains plain ascii chars:


I tried the following and Cabbage also worked fine:

/Users/walshr/Downloads/À test

I’m hesitant to change my language preferences to Japanese in case I can’t return them back to English :grimacing:

I found this issue is not related to language preference because I still see it when I set English preferred language.
I also found that Cabbage patcher can’t configure the connection automatically when this issue happens. Not sure if this is a cause or result of the issue.

This is a minor issue and you don’t have to spend much time on it! :sweat_smile:

It may be, but it is still something that pops up from time to time. And I’ve never been able to reproduce it. Would you mind copying and pasting the path I tested with and seeing if it causes problems on your machine?

I tried the following path and no csd files in this folder can be executed in Cabbage.
Mystery :thinking:

/Users/tetsuya/Downloads/À test

1 Like