Cabbage Logo
Back to Cabbage Site

Cabbage doesn't return any output in both GUI and as Vst

This is kinda an emergency bc I use Cabbage for music studies and while my teacher and I tried to solve this problem we can’t find the solution.

The audio works perfectly on all the other softwares on the pc, even Csound always return what I compile. I looked at the preferences and the right output device was already set (my headset connected to the audio card). I looked into the computer audio settings and it was all in the norm.
I disinstalled the program and reinstalled it but it doesn’t change anything.

I even tried to export it as a Vst3i to then use it on Reaper, but it didn’t change anything (even tho on Reaper I can hear everything else).

Is this a bug? I really don’t know what else I can do.

Hi @TexNick, welcome to the forum, and thanks for reaching out. When you run your instrument are you sure it is connected to the outputs? Open the patcher window, or hit Ctrl/Cmd + p, after you save a .csd file and see that the outputs are connected.

Btw, are you using one of the examples to test or your own .csd file? If it’s your own can you post it so I can test? You can PM if you don’t wish to make it public, although there are no judges of code on this forum!

I’ve never heard of any issues with sound in an exported VST. So it might be the .csd file. Also, what version of Cabbage and what OS are you using?

Hi @rorywalsh, I tried your first advice with the patcher window and it worked! nothing was connected at all, not even the midi to the program. I didn’t even had any idea about the existence of the patcher window so you have been incredibly helpful.

To answer to you questions, I tried both an example test (FM_Clang in the synth instruments) and a csd file that we were making in class: 03Esempio_Chowning_GUI_Cabbage.csd (239 Bytes)

I’m using the Cabbage version
My OS is Windows 10

Thanks a lot for the help, I think I’ll rely a lot on this forum :smiley:

So while the main IDE is now producing sound, you still can’t get anything from the VSTs? Also @TexNick, does the plugin UI show up ago when you try the plugin?

@rorywalsh I also tried to export it as a vst on reaper and it’s all completely fine, it works :slight_smile:
The UI shows up and when I try it it works perfectly.

Since I’m already here though, can you tell me what IDE means?

Integrated Development Environment. I just mean the main Cabbage environment as opposed to a Cabbage plugin :slight_smile: