Cabbage Logo
Back to Cabbage Site

Cabbage Not Working after Update

Hi :slight_smile:
I recently updated my Cabbage but It stops working normally. All the instruments I created and imported from Csound (including Rory’s examples) do not work as I hit the Play button, Cabbage gets stuck and the interface does not show up.

The only things that work are the examples opened from the manual bar, but when I tried editing it by just adding a single knob, it stops working again.

Here is the link to a screen recording of how it looks:

I tried uninstalling Cabbage using CLeanMyMac and reinstalled, tried to reboot my mac, nothing has changed. Please help! Thank you so much :))))

What version are you using? Can you install the very latest hot fix for Csound. It’s 6.16.2, you can find the installer here:

I see you have white spaces in the file path. I too was having issues with this, until I updated to the very latest build of Csound. Let me know if it works. :crossed_fingers:

Hi Rory!

Thanks for the update! I believe this was the version I was using, but I just reinstalled it and Cabbage still stopped working :frowning: It still only works with the examples.

What version of Cabbage are you using, and what’s your OS? And can you try to run an .csd that has no white spaces in the path?

Maybe you can try the latest beta build and let me know?

The latest beta build runs all the instruments! Thank you so much!!!

The only issue is that the content in the menu bar seems to be unavailable now, including examples, manuals, etc. I was trying to explore a standalone app but the pop-up shows that Cabbage cannot be found. The VST version I exported to the Library/Audio/Plug-Ins/VST could also not be found in DAWs. I tried reopening Ableton Live for a few times. I also could not find it in Logic Pro’s Plug-in Manager.

Is there something wrong with importing packages and defining pathways? I saw that there is a folder in the Installer containing all the content. How should I import them? I really appreciate it if you could help me out!

I’m glad you can now run the instruments in Cabbage, the rest of the issue are a result of some teething problems with her new packaging system. I’ll try to get those sorted asap :wink:

I’ve just triggered a new build that should address the resources issues, i.e, the icon and examples menu.Next up is the export problem…

[edit] I’m not having any issues with exported VSTs?

That is great to know! Should I go back to the same link you have sent me to download the new build? Thanks a lot :smiley:

You can access all the latest builds here :slight_smile:

Hi Rory!

Thanks a lot for the update! Sorry for the late response because I was taking care of my family loss ths past week :frowning:
I am new to Pipelines so I am not sure how to download the installer. Could you please briefly explain it to me? I really appreciate your patience and support XD

Click this link:
That will give you a list of all the last builds. Any of them with a green tick are completed. Click on the build you wish to access (most recent at top), then click on the published artefacts link:

If there is a drop down arrow beside the ‘Installers’ label, click it and access the installer you want.

If there isn’t click the three dots on the right and download all installers. :+1: