Cabbage Logo
Back to Cabbage Site

Cabbage on Mac

Hi Rory,

Cabbage installed with the latest beta installers (after 2.8.69) don’t work on MacOS 10.14.6. I tried also building on MacOS 10.14.6 with this error (not sure if this is informative):

->  0x103b303ae <+10>: jae    0x103b303b8               ; <+20>

dyld: Library not loaded: /Library/Frameworks/CsoundLib64.framework/CsoundLib64
  Referenced from: /Volumes/Data2015/Projects/programming/audio_programming/cSound/Cabbage/installers/cabbage-cmake/cabbage/build/Cabbage_artefacts/Debug/
  Reason: no suitable image found.  Did find:
	/Library/Frameworks/CsoundLib64.framework/CsoundLib64: code signature in (/Library/Frameworks/CsoundLib64.framework/CsoundLib64) not valid for use in process using Library Validation: mapped file has no cdhash, completely unsigned? Code has to be at least ad-hoc signed.
	/Library/Frameworks/CsoundLib64.framework/Versions/6.0/CsoundLib64: code signature in (/Library/Frameworks/CsoundLib64.framework/Versions/6.0/CsoundLib64) not valid for use in process using Library Validation: mapped file has no cdhash, completely unsigned? Code has to be at least ad-hoc signed.

Merry Christmas!

The only way I could ensure myself a happy Christmas would be to drop support for Apple entirely :frowning: But don’t worry, I won’t be doing that anytime soon.

What’s odd about your output messages is that it’s referencing your own build of Cabbage?

Yes, I sense the bad Apple, but Cabbage shall prevail! :slight_smile:
Why is it odd that’s referencing my own build, if I sent you the message from Xcode after running my build? The installers from Azure don’t run.

Oh sorry, I thought this error was from the public build. For your own build you probably have to sign the Csound framework. Can you try this:

sudo codesign -s - CsoundLib64.framework --timestamp --deep --force

All this signing stuff is a nightmare.

I’m getting this message after trying to sign:
CsoundLib64.framework: unsealed contents present in the root directory of an embedded framework

Would signing resolve also the Azure builds?
btw. the latest Mac build (with button border fix) was cancelled.

It’s worth a shot. I don’t sign them in Azure because I haven’t been able to set that up remotely.

Hmm, I just re-triggered the build now. :+1:

[edit] The latest build seems to have completed…

Thanks! How shall I sign / make it run after the message below?

Do you also have any suggestions for “home” building?

Very sorry to bother you with this, but I don’t know how to enable later beta’s on my system.

Did you try signing the bundle?

sudo codesign -s - --timestamp --deep --force

I just tried the latest beta package, and it won’t run for me either 🤦 I didn’t have time to investigate but will try later.

Btw @Samo, are you using a public release of Csound, or one of my Csound packages?

I believe I’m using your Csound package, since I have Csound ticked for installation in Azure installer. The version doesn’t change when changing from Cabbage ver. 2.8.68 to 2.8.77. The former runs, latter not.

--Csound version 6.16 (double samples) Aug 23 2021
[commit: c7601d11f029f24590917d4a1797e247eafdef21]

However, signing Cabbage seems to do the trick on the Azure installer :slight_smile:

Is there something similar we can do with “home builds” with Xcode?

I’m happy that I can for now(?) at least use Azure beta updates.

Nice work :clap: Great that we now have a solution for this. My local builds don’t suffer from the same issue. I wonder if Xcode is signing the app here for me, but not for you? Can you try signing the local build?

Sorry, but I’m not sure how to sign the local build. The here gets signed and runs:

But the app seems an older build and I am not sure Xcode actually manages to build:

You need to pull from git in order to get the latest changes. You can also do a clean from the build menu and try again.

I did pull from git. Still, it doesn’t build - error above.

So, it looks like it’s building, but won’t run from within Xcode. Can you sign the application it creates, and then try running it outside of Xcode?

OK. It seems I can sign the app (and it runs through Xcode) now when I found the app in “debug” - I though it would build it in the root where I found an old build. I guess this is all normal? Thanks!!!


I got a bit paranoid by Apple’s “lockdown”…
I hope this doesn’t get worse on the later versions of MacOS. :fearful:

You and I both. I think that sooner or later they will force everyone to release through the app store :face_with_symbols_over_mouth: