Cabbage Logo
Back to Cabbage Site

Cabbage Patcher: clicking on cable/node crashes cabbage

OSX Cabbage(64bit) v2.0.02 ( not sure if these are incremented as I am pretty sure the last few versions i’ve used have had the same number in the about )
OSX v 10.13.6 (17G65)
MacBook Pro (15-inch, 2017)
2.8 GHz Intel Core i7
16 GB 2133 MHz LPDDR3
Intel HD Graphics 630 1536 MB

steps to reproduce:
go to view>cabbage patcher
right click and add any generator example
add any effect
attempt to plug the generator into the effect
click the right channel pin, cabbage dissapears

Can you try this one and let me know?

I tried to recreate the issues you reported but couldn’t. Note I’m on Linux and no access to Mac for a while…

I’m on ubuntu studio, built from master, with the same misbehaviour :frowning:

I can remove wires in the patcher by clicking on the middle of the wire, but when I click on nodes to add a new wire, it dumps core.

backtrace() returned 19 addresses
/usr/local/lib/ [0x7f28ffbb7c04]
/lib/x86_64-linux-gnu/ [0x7f28fee7ff20]
./Cabbage(+0x19af30) [0x563f36f3af30]
./Cabbage(+0x19df9e) [0x563f36f3df9e]
./Cabbage(+0x19ef3b) [0x563f36f3ef3b]
./Cabbage(+0x19bc02) [0x563f36f3bc02]
./Cabbage(+0x19d443) [0x563f36f3d443]
./Cabbage(+0x5d1f0a) [0x563f37371f0a]
./Cabbage(+0x633746) [0x563f373d3746]
./Cabbage(+0x5dfe50) [0x563f3737fe50]
./Cabbage(+0x634c64) [0x563f373d4c64]
./Cabbage(+0x63530d) [0x563f373d530d]
./Cabbage(+0x5e04ad) [0x563f373804ad]
./Cabbage(+0x53d121) [0x563f372dd121]
./Cabbage(+0x466254) [0x563f37206254]
./Cabbage(+0x173cdc) [0x563f36f13cdc]
./Cabbage(+0x173dbf) [0x563f36f13dbf]
/lib/x86_64-linux-gnu/ [0x7f28fee62b97]
./Cabbage(+0x175a3a) [0x563f36f15a3a]
Csound tidy up: Segmentation fault

That’s odd, I can’t recreate the issue? Here’s a screencast. Am I following the steps correctly?

I’m on Arch, with a build from master.

That is indeed what crashes consistently on osx, Ill try your new build and see if it is fixed

still same in new update.


Hmm, looks like it might be specific to OSX then. I’ll take a look when I get back to my OSX workstation.

Good news…kind of…

I can recreate the crash here too. My apologies, I was accidentally testing with an older version. I’ll add it to the list!

1 Like

My best guess is that a rollback or diff check of any changes to the cabbage patcher to the version that works would do it. I feel like it worked ok in the prior versions I installed, seems to be a newer issue in the past couple. Also brings up a good point I may have mentioned in another thread:

I noticed the “about” under the help menu has consistently shown Cabbage (64bit) v2.0.02 and it might be helpful to have the ability to report more detailed version numbers. Not sure if it is difficult to allow multiple installs in OSX (my current main development / design / music creation platform), but that could also potentially be helpful, though not essential.

The problem is due to newer JUCE sources being employed in the more recent versions. Just looking for a fix now.

I know. it is rather annoying. I have a build script that increments version numbers for releases, but not for betas. I’ll try to work out a better system. For now one can always quote the commit tag when downloading the latest betas.

FWIW, It seems like beta testing is where you need the version number for reference most.

Where would I find the commit tag for the github osx package installer download?

It’s the tag that appears on the left hand side under the box with the [Pre-release] label. New beta here