Cabbage Logo
Back to Cabbage Site

Cabbage Plugins not working in Ableton

Hey Rory,

Have just encountered a problem where VSTs I have previously exported from Cabbage are not opening in Ableton, and when I export new ones they don’t even show up in the browser. Never had this issue before - I even sent the .csd to a friend and he had no problems exporting it and then using it in Ableton, then when he sent that VST back to me and I put it in my VST folder it didn’t show up in Ableton. Same problem with VST3 and AU, and with effects and instruments. Unfortunately I don’t have another DAW to test this with. Using Cabbage version 2.3.0, Ableton Live Suite 10.1.7 and macOS 10.14.6


I’ve no encountered this issue before. Did you upgrade anything recently? Would you mind downloading this software and running a scan on the various plugins:

If the plugins are seen there then it’s most likely to do with an upgrade to Live maybe? Although v2.3.0 is the current official release, the current beta is many iterations ahead of it. You might try the latest from the drop link here. You can simply rename your current bundle before installing this one if you don’t want to overwrite the version you have.

Try it out and let me know.

Btw, did you try sending the .vst bundle to your friend to check?

Hey Rory,

Cheers for the reply, sorry I’m only getting around to this now. Tried using Cabbage beta and no joy, I ran that plugin validation and I got the following error for only Cabbage VSTs: “Note that the following files appear to be plugin files, but failed to load correctly”.

Can you send me a link to one of your .vst bundles so I can try it here?

I just tried your .vst bundle and it loads without a problem?

Do they work in the main Cabbage IDE?

I’ve had absolutely no issues with Cabbage. Really weird, could it be something to do with either the build of Csound or some sort of SDK that cabbage needs?

If there was an issue there it would be picked up in the Cabbage IDE.

No, all of this is taken care of in the Cabbage binaries. Are you using a standard version of Csound, or your own build? What version?

Hey Rory,

I’ve actually just managed to fix this. If you remember this thread, I had my Cabbage relinked to csound built from source in usr/local/Frameworks because some libraries weren’t loading while using the regular install in /Library/Frameworks. Well, I linked Cabbage back to /Library/Frameworks, tested a VST and it was working (but I was getting the library warnings again), then linked it again to /usr/local/Frameworks, and everything is still fine. Weird, but sorted! Cheers

1 Like

Sounds like a shit show :rofl: But thanks for letting us know that you sorted it out!