Cabbage Logo
Back to Cabbage Site

Cabbage VST export not working, CSound seemingly to blame

I’m trying to use the Feature-Extract-Modulator toolkit (for cross adaptive processing) for my master’s thesis. Oeyvind Brandtsegg created it, it’s available at, and Cabbage runs the GUI. I’m super short on time :hot_face: and it’s not working properly in Reaper when I export it to VST. Namely, all the low-level audio feature event detection channels (OSC signals) are unresponsive – only this one pitch monitor seems to be receiving audio. Furthermore, upon exporting, Cabbage has consistently given me the same error:

“The plugin ID identifier in /Volumes/Macintosh HD/Users//Downloads/featexmod-master/analyzer.csd [or vst_mediator_interprocess.csd or vst_MIDIator_interprocess.csd] is empty, or the pluginid identifier string contains a typo. Certain hosts may not recognize your plugin. Please use a unique ID for each plugin.”

Swear I haven’t changed any of the original toolkit code. But I’ve uninstalled then re-downloaded the toolkit from GitHub, uninstalled Cabbage 2.7 to install the current 2.8, and Homebrew-reinstalled Csound at the Terminal (I’m running an OS X 10.14.5). With the new Cabbage install, the plugin windows would not come up when I tried running each of them. In Reaper, they came up, but were still unresponsive.

NOTE: A few times during the Csound reinstall process I had to force the symlink (tbh didn’t really know what it was) and overwrite conflicting files. I ended up doing the following commands at diff points:
brew link --overwrite libtool … which resulted in error requiring me to
brew link --overwrite pkg-config … then an error requiring me to
brew link --overwrite libevent
… at which point there seemed to be no more terminal errors.

Following the instructions in the FeatExMod github page, I made sure to upgrade my python directories (GUI code is in part generated by python), then I did
pip install pykalman, numpy, and matplotlib.

BUT THEN, when the plugins were still unresponsive in Reaper, I decided to try running a random Csound file in the Terminal, namely /csound-develop/examples/plugin/opcodes.csd, and I saw that it brought me the same warnings generated in the plugin host in Reaper:

WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libfluidOpcodes.dylib’ (-1)

WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libvirtual.dylib’ (-1)

WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/librtjack.dylib’ (-1)

soooooo… does anyone have any ideas? I need this working like yesterday I would appreciate any insight so much.

That’s a huge project, and I’ve no idea why these don’t run. Oeyvind wrote this system using a much older version of Cabbage. It might have even been Cabbage 1. There are likely many updates needed for it to work with the latest version. I think you may have to reach out to the author on this one. But I’d say the chance of getting this sort like yesterday zero to none. It will probably be quite a bit of work.

p.s. the plugin ID error and those other warnings won’t have any affect on whether it works or not.

Oh yikes. (FWIW I did reach out to Oeyvind as well, hopefully he sees the message soon.) If the problem is potentially just the working version of Cabbage I’m using, then shouldn’t I just uninstall, then download one of the Cabbage legacy versions? It works perfectly on Oeyvind’s system, I’ve seen it running there. Plus he last updated code from the toolkit 2 years ago, so I should just reference whichever Cabbage update was current at that point, no?

Yes, you can try installing an older version of Cabbage. You’ll find older versions on the Cabbage GitHub site under releases. You might also need to install an older version of Csound.:+1:

So my thought is I should downgrade to Csound 6.13 (released Jul 12, 2019) and Cabbage 2.1.05 (Jun 17, 2019) since they were respectively the latest versions the last time Oeyvind upgraded the toolkit. Is there a more direct way to uninstall Csound than dragging every directory to the trash? Like a terminal command? It spreads a lot of files around and I want to be sure I’m doing this as cleanly and efficiently as possible.

Csound doesn’t spread any files around. They are all contained within the Csound64Lib.framework. I usually just rename this when I’m testing other versions of Csound. Btw, Oeyvind might have last updated his code in 2019, but there is every chance he was using a version of Cabbage from before then.