Cabbage Logo
Back to Cabbage Site

Cabbage vst2 plugins get blacklisted in Ardour/Mixbus

Hi I used MultiReverb Example that comes with Cabbage
I see it’s working in Carla
But Mixbus and Ardour put it to blacklist (.cache/ardour5/vst64_blacklist.txt)
Same happens to Cabbage-plugins from kxstudio
I’m running Ardour 5.12 on debian linux
Did anybody face this? Maybe someone knows how to overcome it?

What version of Cabbage are you using? Note that the Cabbage-plugins from KXStudio are likely linked against an older version of Csound. This might be causing problems there. But the plugins created with your own build should work just fine.

Hi @alikthename. So I just tried here and got the same problem. I’ll need to run it through the debugger to see what’s going on. Sorry about this. I might get a chance tonight to look into it, otherwise, it will be first thing tomorrow morning, Irish time :wink: I have a feeling the plugin is not finding the .csd file. I’m just not sure why.

Hi @rorywalsh, thanks for your time. looking forward. So far all my generated plugins got blacklisted, although there is pvsBlur from mentioned kxstudio package, could make it somehow

Just looking into it now. You don’t happen to know if there is a way to run Ardour directly, without having to run the Ardour5 script? I need to attach a debugger to the Ardour process, but all attempt to run it outside the startup script are failing…

[edit] I’m going to install the version linked to kxstudio and see if that is easier to work with…

[edit] not much better there. I can attach gdb to Ardour once it’s running but the plugins seem to be already blacklisted at that stage. Hmm…

there was a discussion with tech support on Mixbus forum about how plugins get blacklisted :

RE: What happens with a blacklisted plugin?

Normal operation is:

  1. Mixbus creates an entry for a plugin in the “blacklist”.
  2. Mixbus scans the plugin.
  3. If the plugin completes normally without crashing or timing-out, then Mixbus removes the entry in the “blacklist” and adds an entry to the plugin cache list.

If step 2 fails ( the plugin crashes the scanner app, and/or doesn’t respond ) then Mixbus leaves the entry in the blacklist and moves to the next plugin.

As kmsaudio showed, you can clear the “blacklist” and try to re-scan plugins if you’d like to try again ( for example if you’ve downloaded a newer or older version of the plugin that might work )

Also there is a debug version of ardour on their site, although I can’t seem yet to find it there

Thank for that. I think I have it sorted now. There were some conflicts between a library Cabbage doesn’t actually need, and Ardour. Simply removing the linking of said library in Cabbage seems to have done the trick. I also fixed the issue with the examples menu not showing correctly.

Can you pull from the dev branch again and try runing the buildCabbage and installCabbage scripts? I think it should work fine now.

ok will try and message back

compiled latest commit, and now plugins don’t get blacklisted
But no sound no gui
Same was with previous version, I did the trick mentioned in Linux VST export, no GUI/no sound and it worked back then

But now it doesn’t somehow

That’s odd, in my tests yesterday the GUI was showing without any issues. I didn’t check the audio as I assumed it was working. I will try again now with a different Linux machine and see if it works for me there. I’ll let you know. Thanks for your patience!

[edit] I’m seeing the same thing are you on this machine. Let me dig a little deeper…

Hi @alikthename. Can you try again when you get a chance. It looks like I forgot to commit a change to the build script. That explains why it ran on my home PC but not my work one. I just tested and Iain McCurdy’s LoFi bit cruncher has never sounded so good :wink:

Hi @rorywalsh, sounds nice indeed. But here’s another interesting thing. Ardour likes it so much that it won’t allow any other cabbage plugin to be found in plugin manager. It kind of “thinks” other plugins are duplicates of it. Somehow it finds out similarity in binaries. Now if I remove Lo-Fi with it’s .csd from plugins folder and put with corresponding .csd there, then reopen session with Lo-Fi on certain channel. In this situation Ardour/Mixbus should tell me it didn’t find the plugin, disable and grey it out. Instead DAW now puts Compressor in its place while still calling it Lo-Fi. Reaper does the same

Oh dear. That doesn’t sound good. Thanks for reporting. The thing is, they basically are the same binary, apart from their name. I’ll take a look.

I’m going to have to ask on the Ardour list. While plugin binaries are similar, they are certainly not the exact same.

what I see in carla there is an ID for every plugin and they`re different for different plugins. in case of cabbage they’re same

with Ardour (and qtractor) from debian 10 repository and Cabbage 2.3.0 from source I had not this kind of problem (I’ve removed the “standalone” checkbox in projucer when compiling cabbage) with the plugin I’m developing (involves filters, compressors and image update on the gui from csound).

Did notice instead that with bypassed plugin (from the daw) or with csound doing nothing (basically passing input to output) there is a change in sound but I’ve a suspect that there is something in my code (not so flat bandpasses filters).

But I didn’t notice vst pluging in the black list, it’s either working or not showing gui (see projucer checkbox solution).


Thanks @vallste. Looks like you’re right @alikthename, I just did a check here and the plugin ID is not being set. Should be a simple fix. I’ll let you know…

Should be all good now :crossed_fingers: If anyone has a chance to try it out please let me know.

Looks working now @rorywalsh . Thanks a lot!

I ran into the same problem but even with the cabbage devel branch, the synths (ToneZ & my June-21) I scan with ardour and end up in the blacklist.

The thing that solved the problem was to use Ubuntu Ardour build (1:5.12.0-3) from disco repository, instead of kxstudio version.

I now can load my cabbage plugins (even without a latest cabbage build)