Cabbage Logo
Back to Cabbage Site

Cannot find the AUs I've created with Cabbage in Logic Pro X


I am very new to Cabbage, so this might be easily fixed, but I can’t seem to find the solution. I installed Cabbage a couple days ago, and yesterday I created a synth using Cabbage. I exported it by using Export Plugin -> AU Export -> Export as AU Plugin Synth. I then moved the component to the correct folder in the library. However, the AU doesn’t show up in Logic’s Plug-in manager.

I feel like I have tried everything; restarting Logic, restarting my mac, clearing the Audio Units Cache, exporting the plugin directly into the correct folder (instead of moving it from “Documents” to the Plugin-folder), but nothing happens. The plugin shows up in Ableton and I have been able to play the synth in Ableton without any problems, so I’m pretty sure it’s correctly exported. I tried sending the files to some friends and they couldn’t use them in Logic either, so it might be a problem with Logic.

Any help is appreciated, as I only have the trial version of Ableton and I am not able to record anything I play with the synth in Ableton, so I would really like to be able to use it in Logic.

What happens when you run auval -a from the command line? I have just recently got a copy of Logic, but I’ve not seen those problems. Are you trying some of the example that ship with Cabbage?

[edit] Can you also try exporting an effect, and see if that gets validated by auval

Wow, now I’m having the exact same problem :thinking: Effects work fine however. I’m currently looking into it…

When I run auval, nothing from Cabbage shows up. I tried exporting some of the examples that come with Cabbage, both synths and effects, and they do not show up either in the auval “list”. However, BOTH effects and synths that were exported from the examples DO show up in Logic, but the one I created myself does not. Is it possible that the code is too simple, maybe there’s something missing in the coding itself? But that also seems strange considering it works fine in Ableton…

A restart did the job for me. How can auval not show them, but Logic does? Logic uses auval to validate its plugins too. How bizarre. What happens if you run the plugin manager in Logic on the Cabbage plugins, does it end up clearing them from the list? I assume you are also clearing the au cache regularly? Also, note that you should use a unique pluginid for each of your own plugins. If there was an error in your plugin code auval should show it.

Can you try this version. I did some work on the AU side of things today that might improve things a bit. Once you install this version, clear your AU cache and try exporting one of the basic plugins in Cabbage. Then run auval and see if it catches it. I just tested here and it worked fine, I hope it will also work fine for you.

Running the plugin manager in Logic on the Cabbage plugins returns a successful validation, and does not remove them from the list.

I cleared the AU cache earlier today when trying to figure out what was wrong, but that was the first and so far only time I have done that (as all this plug-in stuff is pretty new to me, including using an Apple product).

I did write pluginid(“random letters and numbers”) in the code, so I think it has a unique ID, if that is the correct way to give a plugin an ID?

I did this, and it happened again: Does not show up in the terminal window when I run auval, but I can find the plug-ins in Logic, while still being unable to find the one I created.

It should be four alphanumeric characters.

I usually run a command to clear the AudioUnit cache each time I run auval. No two AUs can have the same ID.

Do the ones that are shown in Logic actually work? Can you instantiate them and use them? It’s most strange that auval when called from Logic finds the plugins, but not when run from the command line.

Btw, what version of MacOS are you using? Also, I’m not sure if you have Reaper, but the demo version is fully functional and does not impose any time restrictions. It’s a good tool for testing plugins too. You might also try this tool, pluginval. Launch that and do a scan for your AUs. I’m curious to see if it sees the ones you exported from Cabbage.

Yes, I can play and use them.

I am running on Mojave 10.14.6 (so, not yet updated to Catalina). I downloaded Reaper, and turns out that I can find and use the VST version of the synth I created, but not any of the AU exports - but the example synths, which I also exported as AU, do turn up in Reaper.

Launched this and this finds the example synths and effects, but not the one I created.

So, I tried something: I removed all the code from one of the example synth files, copied the code from the file I created yesterday, and placed it into the file of the example synth, and then saved the file as something new by using File -> Save File As… and then exported it as an AU. And now the plug-in shows up in Logic under AU Instruments -> CabbageAudio, where the example synths are also found, and I can now use the synth. It now also shows up in the pluginval tool, with CabbageAudio as manufacturer.

Neither the example synths nor my synth show up when I run auval, but at least I found a way to open my synth in Logic, even though it is a rather convoluted way.

How odd. But all instrument you export from Cabbage should should show up there under “CabageAudio”. Would you mind zipping the .component that is not working and sending me a link so I can look through it. I’ve no come across this issue before. I would like to get to the bottom of it.

I might upgrade to 10.14, I’m still running 10.13…

Here is a zip, I’ve included both the working component and the one that doesn’t work so that they can be compared. As far as I can tell the only difference is the pluginID, so it is definitely odd.

Thanks. I’ll try it and see what happens. :+1:

Both of these are showing up for me when I run auval. I didn’t need to restart, clear the audio unit cache or anything like that. Now I’m even more confused about what might be happening… :thinking: