Cabbage Logo
Back to Cabbage Site

Commenting out Cabbage source problems


Type “asterisk” / anywhere in your csd source code and Cabbage will become unresponsive.
Accidentally found this out when I was uncommenting a section of my source code but did it only partially.

Using version 2.5.19 on Windows 10 64-bit.

Do I have to save after I type the asterisk? I’m not able to recreate that issue here… :thinking:

No, type it in and play. Tried that in some example files with the same result.
it’s asterisk slash, the last part from a comment. */

Ok. Something weird is going on.
Installed Cabbage on my laptop and I don’t have the problem, get a syntax error instead.

Probably something wrong with my desktop then.
I will look at it and try to figure out what’s going on.

I let you know something later on.

On my laptop:
Installed 2.5.19 -> no problem, syntax error
installed 2.5.20 (overwriting 2.5.19) -> problem appears, lock-up
Installed 2.5.19 (overwriting 2.5.20) -> still problem, lock-up
Completely uninstalled Cabbage + Csound -> reboot
Install 2.5.19 again - problem still exists

So the conclusion is that when 2.5.20 was installed the lock-up was introduced and it does not disappear by downgrading.
Maybe you can recreate it this way.

I can’t recreate here?

Something strange is going on.

You can detect this problem in most file player programs except the following:


These three are fine.

Please check when you have time. It’s not an urgent problem.

1 Like

Yeah, I can recreate this now. Thanks, I’ll take a look…

1 Like

I finally found that bug. :exploding_head: I’ll push a fix shortly. I also sorted that other issues regarding the legacy style buttons. :+1:

1 Like

Commenting out bug solution confirmed working in 2.5.22. :+1:

1 Like