Cabbage Logo
Back to Cabbage Site

CSound 7.0

Attempting a new build on Ubuntu. According to the Cabbage build 2.8 v6.X or greater CSound required. However, building the latest CSound from Git = CSound 7.0 which I’ve not got installed - build 2.8 will not work with this. Error message in logs is it’s trying to find 6 etc.

Does the latest version of Cabbage on Github (for compilation) work with CSound 7.0?


You’ll need to build Cabbage from source if you want to try out Csound 7. But Csound 7 is a long way off yet.

Not sure about that - Csound 7.0 beta Feb 27 2022 is what’s installed on my system by following the 'how to install bog standard Csound from the link in the Cabbage - the latest up on Github is 7.0 so I guess I’ll need to use the latest stable master flag.

It’s not that I want to try 7.0 it’s that 7.0 is what installs as a matter of course now without the flag.
Anyway, thanks for confirming Cabbage will build with it but I get the impression I’d be better off getting rid of 7.0 and using 6.17.

Cool that worked - went the easy route and downgraded to 6.17.

Thanks Rory :slight_smile:

Thanks for letting us know. I haven’t tried Cs7 yet as I know it’s still very much untested. I think the master branch is still 6.17?

Morning. on new build seems like in old school mode chnset is not updating gentables anymore. i have one device still in old mode. maybe its time to rewrite)

its updating only when close then open interface

this string i mean chnset “tableNumber(1)”,“table”

Can you reproduce it with a simplified example?

I’ve noticed this too. Here are two simple examples attempting the same gentable updating. The first, using guiMode(“queue”) and the second using the old method of identChannel and chnset. Please tell me if I’m missing something.

Here are the two files:
chnset.csd (627 Bytes) guiModeQueue.csd (711 Bytes)

Perfect, I will get cracking on a fix for this. It might not be till middle of next week unless I am lucky enough to find some free time between then and now :+1:

1 Like

This should be fixed now guys. Can you let me know. :+1:

Looks good here. :+1: