Cabbage Logo
Back to Cabbage Site

Csound.hpp not found when compiling Cabbage

I am trying to compile Cabbage on Linux Mint. I get this cound.hpp file not found. Installed cound with apt-get, but the /usr/local/includes file is empty…


I think you need to install the csound-dev package? The recommended way of doing this is to build Csound yourself from source. It should be pretty trivial to build. Let me know if you have any issues.

I tried to install csound-dev, but that package does not exist. I had already installed csound64-dev, but that did not do it either. BTW, csound 6.10 is installed and running. Does Cabbage only need this include file, or also .so files?

You’ll need at least Csound 6.13. Cabbage links to the Csound lib, so it definitely needs those .so files.

Ok, I compiled Csound on Mint, it is now version 6.15.
But some errors occurred during the Cabbage build process:

In file included from …/…/JuceLibraryCode/modules/juce_audio_plugin_client/juce_audio_plugin_client_VST2.cpp:26:0,
from …/…/JuceLibraryCode/include_juce_audio_plugin_client_VST2.cpp:9:
…/…/JuceLibraryCode/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp:87:10: fatal error: pluginterfaces/vst2.x/aeffect.h: No such file or directory
#include “pluginterfaces/vst2.x/aeffect.h”


In file included from …/…/JuceLibraryCode/include_juce_graphics.cpp:9:0:
…/…/JuceLibraryCode/modules/juce_graphics/juce_graphics.cpp:92:12: fatal error: ft2build.h: No such file or directory
#include <ft2build.h>

Any idea?

You’ll need the vst2.4 ask, and I think the other error is related to webkit? Check the repo, there is a build Linux script in the root folder that has all the steps you need to build. :+1:

I have downloaded the VST_SDK from Steinberg, and that contains also the following:
VST_SDK\VST2_SDK\public.sdk\source\vst2.x. This contains some .h and .cpp files that resemble (but not exact) the file being asked for. See screenshot.
So it looks like vst2.x is still there. Is that something we can use? Maybe change something in the source code?
Screenshot from 2020-10-04 14-36-29

The VST2.4 SDK is no longer available from Steinberg, although they have a place holder for it in their sources. You will need to get it yourself somewhere. You should really look at the build linux script in the root folder of the repo. It’s basically a step by step list of instructions on how to build from scratch on any flavour of Linux. :wink:

Ok, I just executed the Linux build script. That seemed to solve some missing dependencies. Then I executed the cabbageBuild script. All seemed to go well (no errors during the build), but in the end I got:

Copying over docs and icons…
/tmp/ccdbfoBz.o: In function Csound::LoadPlugins(char const*)': testCsoundFile.cpp:(.text._ZN6Csound11LoadPluginsEPKc[_ZN6Csound11LoadPluginsEPKc]+0x23): undefined reference to csoundLoadPlugins’
/tmp/ccdbfoBz.o: In function Csound::GetInputName()': testCsoundFile.cpp:(.text._ZN6Csound12GetInputNameEv[_ZN6Csound12GetInputNameEv]+0x18): undefined reference to csoundGetInputName’
collect2: error: ld returned 1 exit status

Comment out the command that builds testCsoundFile.cpp and you should be grand. In fact, it probably built ok. Check the install bin folder…

Well, there is a CabbageLite and Cabbage file in that folder, but I cannot start them. They are of unknown file type…

That Cabbage file is the application binary. I’m not sure why it won’t start. I used to build Cabbage on Mint all the time until I switched back to plain old Ubuntu. I don’t see what the problem might be.

I had to add .sh to the file name and now it runs.
Well, I cannot open any of the examples. Only Effects and Instruments are highlighted in the menu, but nothing further is highlighted…

Did you run If not then you won’t have access to the examples through the example menu. If you don’t want to install globally you can set the examples directory in the Cabbage settings. After that they should appear in the menu :wink:

I did it just now. Had to use sudo. It now works, but all the examples I heard generate a crackling audio (distorted)…

Are you using Jack? I only ever test with Jack. I think some people have got Cabbage running with non-Jack drivers, but I never bothered. I use Cadence to manage my Jack sessions and find it rather painless.

I was using ALSA, will try Jack now.
Hmm, I get no sound with jack, test button produces none. The output shows ‘system’
I use qjackctl…

Ok, somehow now it works, I started jack first and then Cabbage, maybe that did the trick…

1 Like