Cabbage Logo
Back to Cabbage Site

DAW playback issues

I’ve gotten my synth working in Logic (Finally!) and, when played into live via keyboard, the synth performs beautifully and does everything I want it to. Though, when I feed it notes via a piano roll, it performs them way out of time and offbeat. The first couple of notes are usually timed correctly, though, after three or four, they begin to anticipate their place in the piano roll by a few milliseconds, making their implementation in a DAW sequence nearly impossible.

What might be going on here? Is there something about Logic’s MIDI coordination that my synth isn’t able to interpret?

What version of Cabbage are you using? Can you try setting ksmps to 1. Btw, I’m concerned that it took so long to get your synth working in logic. It should really be as simple as exporting to the right place, and opening Logic.

The first several iterations of my synth worked fine. Eventually they stopped showing up as available AU plugins. I think changing the plugin ID fixed this, as though Logic wouldn’t recognize multiple AU components with the same plugin ID, just the first one it scans with a given ID… that is just a hypothesis

Oh yes, that might be it. The whole AudioUnit cache thing can be frustrating. When in doubt you should clear the cache. I think one iteration of macOS even required a restart after cleaning the cache :roll_eyes:

So, I tried setting ksmps to 1 and I got loads of clicks and pops while playing the synth. The synth was slightly less click-y and poppy with each doubling of the ksmps number, and I could only get it to go away entirely by switching it back to 32. Though, when it was at 1, I didn’t have any latency issues with midi playback. Any idea on how to compromise here?

Can you send me your synth so I can test this myself? You can PM me if you don’t want to put it out in the public domain just yet.

Btw, you never said which version of Cabbage you are using…

I just tried this here with one of the instruments that ships with Cabbage and I see now issue at all. To test, I set up a simple repeating note and got both a Cabbage synth and a Logic synth to play the clip at the same time. If there are problems I would have expected the two tracks to move out of sync, but they stay perfectly aligned.!Ah4mHoWvP_GcjQxBh2UO0DhLrRT7?e=9eVgUq

Something tells me you’re not using the latest version of Cabbage. Just in case, you can try the lates beta version here and let me know if the problem persists.