Cabbage Logo
Back to Cabbage Site

Editor and DAW crashes after updating Cabbage

Not sure how related the issues are, but I updated Cabbage today to version 2.8.0 and two issues started happening:

  1. Cabbage won’t play the code when running the editor. When I click the play button the application crashes immediately.
  2. My previously exported effects and instruments crash my DAWs (tried on both Reaper and Cubase) as soon as I try to instantiate them

I’m on MacOS 10.15.17. Everything was working smoothly this week before updating. I also tried to get the latest beta package but that didn’t seem to fix it. Any help is very much appreciated!

Edit: Example files are also crashing Cabbage when I try to play them

can you try the latest beta again. No point in using 2.8. If previous plug-ins crash it’s most likely to do with your version of Csound. Can you let me know what version of Csound you are using?

did you update Csound when installing Cabbage?

Ok, I’m on Cabbage version 2.8.117 and the problem persists. I did update Csound when installing (v6.16 according to the installer) :confused:

I cannot recreate this crash here with any of the example files. To be honest I would expect an avalanche of reports if the latest Cabbage was crashing on Mac OS. Can you try uninstalling see sound from the frameworks folder, simply delete it or rename it. Then install Csound from the sea sound download section on the Csound website. Then try cabbage again.

Reinstalling Csound from the Csound website seems to have fixed it, thanks!

Thanks for reporting back. I will take a look and see what the problem is when I get a chance.

1 Like

not sure if that’s helpful, but the Cabbage installer seemed to be using Csound 6.16 while I got 6.17 from the Csound website

1 Like