Cabbage Logo
Back to Cabbage Site

fluidEngine instantiation throws error


I wanted to try out the fluidEngine in CSound, since it seems to be an easy way to get sample based instruments up and running quickly. However, the instantiation of the engine throws an error:

>>>giengine	fluidEngine <<<
Unexpected untyped word giengine when expecting a variable

I have tried it with the example from the manual ( and the one Rory posted here on the forums (Fluidsynth or multi sample player example for Cabbage?).
Does anyone know why this happens? Shouldn’t the gi part of giengine be the type of the variable that csound is looking for?

Which Csound IDE are you using? Csound version?

Also, are the fluid opcodes even included any more with the base installer? I think you might have to grab them from the CsoundPluginOpcodes repo?

yeah, they’re here now.

I had forgotten it was I who put the windows package together :laughing: Note that widgets.dll causes a crash in Cabbage. So don’t put that one in the system path…

I built the plugins and installed them, everything worked, except that the FluidSynth package could not be found during the build and consquently also was not installed :sweat_smile::

CMake Warning (dev) at /usr/local/Cellar/cmake/3.22.0/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:438 (message):
  The package name passed to `find_package_handle_standard_args` (FluidSynth)
  does not match the name of the calling package (FLUIDSYNTH).  This can lead
  to problems in calling code that expects `find_package` result variables
  (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
  cmake/Modules/FindFLUIDSYNTH.cmake:33 (find_package_handle_standard_args)
  fluidOpcodes/CMakeLists.txt:3 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.


I use Cabbage/CabbageLite 2.8.0 and/or thr CLI with CSound 6.17.0 on Mac OS.

EDIT: nevermind, I forgot to install FluidSynth beforehand :see_no_evil:

There is a package there with all the plugin pre-built. Just look at the releases section. fluid is a bit of a beast. The Csound implementation still uses the older version of fluid as far as I know. Also, you can find new beta builds for Cabbage here. 2.8.0 is over 100 iterations behind the current beta. Check out this sticky about how to access the betas.

1 Like

I installed fluid via Homebrew and ran built the plugins again. The build script defaulted to the local fluid library, so I guess it is using the current version (2.2.5). It seems to work fine with the Cabbage Lite version I have installed, but I will definetly check out the beta version.

Thanks for your help!

Btw, CabbageLite is no longer supported :grimacing: Is there a particular reason why you are prefer to use it over the main IDE?

I usually use one editor for all my code (vscode since I started using unity), so using cabbage lite seemed like the obvious choice to get the plugin ui and console while writing the code in vscode.

I hear you. I find I do a lot of editing with VS Code too.

Oh wow. Had no idea what CabbageLite was. As another VS Code user, this is great.

Oh no!! :rofl: I really don’t want to have to support this. I’m waiting to hear back from @t_grey on the use of the standalone apps as an alternative to CabbageLite - He is our resident Cabbage external editor expert :wink: