Cabbage Logo
Back to Cabbage Site

FluidSynth issues in OSX Cabbage

Hi Rory, using Cabbage for prototyping a midi manipulator for a client which involves using Soundfonts as the sound source, I tested with the client and with a friend whos also on OSX and they’re getting the same issue, where the FluidSynth opcodes don’t seem to be being recognized, and are throwing errors on OSX but not on my windows 10 laptop.
Client:
Cabbage Version: 2.1.05b
OSX: Mojave 10.14.2
Csound: 6.13.0

Me:
Cabbage Version: 2.1.04
Windows 10
Csound: 6.12 beta

Issue is being thrown in this instrument:
instr Initialise giEngineOne fluidEngine iSoundfontOne fluidLoad "jRhodes3b-stereo.sf2", giEngineOne, 1 fluidProgramSelect giEngineOne, 1, iSoundfontOne, 0, 0 kLine = 0 while kLine != -1 do Sscore, kLine readf "Score.txt" scoreline Sscore, 1 od turnon "Output" turnoff endin

Is this a known issue? I asked the client to update to the latest version of cabbage which he did, and the same error was thrown,
Cheers,
Syl

(Edit: The fluid opcodes work on his PC, but not on the two OSX devices we’ve tested with)

Have you tried a simple fluid test with vanilla Csound on OSX? I’ve not seen this issue before :thinking:

will write him a file to test it, super weird right? will let you know what the results are

Looks like there is an issue with the current Csound installer for OSX. I just tried here myself and I see the same problem. I just wrote to Victor to let me know.

[EDIT] It seems that they require JackDMP on OSX. If you install Jack for OSX it will sort the issue. Victor is looking at a way of removing that dependency.

Yo thank you so much you saved us hours of confusion, will let him know, do have another minor issue but is probably just me being stupid, will open a new thread!