Cabbage Logo
Back to Cabbage Site

Fmod doesn't recognize plugin

Good idea. Here you go:

I didn’t have a chance to test the plugins earlier, but I’m on my home machine now, and I can confirm that this plugin loads and runs fine…

Unfortunately it doesn’t show up. I installed a fresh version of fmod studio and it didn’t help.

Does the FMOD Console window print anything of note? I also just did a fresh install of FMOD. And it works fine where. Hmm. Any other ideas? Can you try putting the fmod plugin folder somewhere else? Perhaps there are permission issues with your desktop folder. Try somewhere in “My Documents” perhaps.

The console prints:
20:15:07 fmod_os_misc.cpp(784), FMOD_OS_Library_Load(): LoadLibrary failed to open ‘D:/FMODPlugs/bells.dll’, GetLastError = 126 [#2 times]
20:15:07 Error loading plugin D:/FMODPlugs/bells.dll: File not found.

so there is that.
Moving the folder to My Documents didn’t work.
I could try to get another third party plugin to see if that shows up. At least we could find out for sure that it is fmod’s issue. Can you recommend any plugin I could test?

I haven’t actually used FMOD is quite some time, so I don’t know of any 3rd party plugins. But it would be good to test one as see. Let me know. Something very strange is happening, but I can’t tell what it is.

Hi rory! I was trying to do one of my subject’s work, based on putting sound with a new created plugin using fmod and cabbage for it. I have the same problem as the guy in this forum. I’ve followed all the stages of your explanation, but i cant fix the problem. As you didnt keep on talking about the problem, i cant find any way to fix it. Could you help me please?? It’s very important to pass the subject in 2 months!!

I didn’t reply again because I was waiting for confirmation on whether other 3rd party plugins work. As I mentioned above, it works ok for me. The question is, how can I fix a problem that I can’t create? Can you confirm that other 3rd party plugins work for you. Are you also using Windows?

Sorry for not replying earlier.
I didn’t manage to find any other 3rd party plugins so I put it on hold and have been setting up another system on my mac to work side by side with the windows one. FMOD studio on mac also crashes when loading cabbage plugins but I need to test it more.
I asked the question on the FMOD forum, however, and they referred me back here (my other post).

I will check in my Mac tomorrow and let you know. It would be great in fact if I can recreate the problem there. Might help me find a fix that will work on Windows.

All plugins that i’ve tested dont appear in fmod “Add plugin Instrument”. We are 2 guys trying to add plugins in our respective Windows OS, but we have the same problem.

Do non Cabbage plugins work?

@MiguelBedia, @P_G_Vasilantonakis I don’t know what else I can do here. This is working fine for me on all platforms I try on.

To be absolutely certain, I just rebuilt the Csound FMOD plugin on OSX earlier this morning and it still works as I expect. You really need to confirm if you can load 3rd party plugins. That’s the only way we can tell if this is an issue with the Csound FMOD plugins, or a problem loading 3rd party plugins in general on your machines. The ball is in your court now. There is not much else I can do without your help.

Hey guys, I just tried this out on another Windows 10 PC and everything works fine for me. I don’t know what to say here. It seems that something must be up with your setup. I’ve now tried on 4 different Win10 machines, and 2 different OSX machines, and I just can’t recreate the problems you’re having. Here is the dd and .csd file I just tried with the latest version of FMOD. Let me know how it goes. And PLEASE, try another third party plugin if you can. (43.2 KB)

Ok, this is where it’ll get weird. FMOD on Windows 10 now recognizes plugins exported with Cabbage. I’ve run the bells example as well as one I had exported a while back. I didn’t change anything obvious in how Cabbage or FMOD are set up.
These are the only differences in my machine that I can think of that could be making an impact:

  1. I installed distributions for C++ in my Visual Studio.
  2. I installed the FMOD api

Perhaps there was a system DLL missing. I’m glad it’s working. I hope @MiguelBedia can get it working too. :crossed_fingers:

Hi @rorywalsh !,

I’m @MiguelBedia 's partner. All we can say is that all the plugins we’ve tried in our machines still dont work for us. Even the 3rd party plugin you told us to try, it’s still not working. We also tried to reinstall Fmod and cabbage plugin in their latest versions and it doesnt work. We dont know what to do in order to solve this. Because we’ve tried everything…

If the 3rd party plugins don’t work then it looks like something is up with the system. I’m sorry I can’t offer more help. Perhaps you can contact the developers of one of the third party plugins you tried and ask if they might have any ideas why it’s not working? It’s usually a permissions issues but I think you have already checked for that. If you do find the solution please let us know. Btw, were you able to try on different machines?

At the end out teacher told us not to use fmod in our work, only the desing of the plugin. By the way, i have problem with the widgets color. When i put the code in setting mode, where i can change the width and all that stuff of the color, when i go to the right panel options in the new cabbage version, it change the values number in th but no the color itself. When i pick a colour in the panel colour section, it doesnt change the colour. Dont know why, any sugestion? It seems like that right panel diesnt work for me.

So it doesn’t behave like this for you? Might be an idea to open a new thread about it…

yep… it doesnt work to me