Cabbage Logo
Back to Cabbage Site

Fonts not working on labels

Hey, I’m relatively new to Cabbage but loving it so far

When using different font styles I can’t seem to get them to work on the labels.

I’m using Cabbage 2.8.0 on MacOS Monterey 12.6…

This should be the relevant code snippets here in my cabbage section:

form caption("SCANNER") size(870, 400), openGL(1) guiMode("queue"), bundle("./MTX", "./Scanner.snaps") typeface("wearealien.ttf") pluginId("SCNd"), colour(255, 140, 240) titleBarColour(255, 100, 255, 255), fontColour(255, 200, 255, 255)
label bounds(0, 10, 870, 50), text("S C A N N E R"), fontColour(255, 210, 255, 255) align("centre")

Also here is a screenshot of the plugin:

I’m not sure if this is Actually a bug or if I’m just doing a bit of an oopsie somewhere, hence why I’m posting into the Stew… if you need more of the code just tag me and I’ll post the rest of it here


Do you mean things like bold, italic, etc? They will only work if the ttf file has them.

See that’s what I thought it was at first too, but when I removed that part from the code it still wasn’t working. I can’t seem to get the fonts to work on certain widgets: labels are one of them, and infobuttons are another that I noticed the other day

I just tested this her and I too see some issues. I’ll take a look tomorrow and report back :+1:

Excellent, Thanks!!

I just tried this again with the latest beta build and it’s working Ok. What version of Cabbage are you using?

Just checked, the version I’m using is 2.8.0

Ah, right, that’ pretty old (even though is the most recent ‘release’). You can grab the latest platform beta from here. Click the three dots to the right of the installers button and download. :+1:

Awesome! Just tried it out and everything is in order, Thanks!

1 Like