Cabbage Logo
Back to Cabbage Site

Fresh Cabbage

I’ve posted binaries for Cabbage v2.1 and updated links on the wbesite. I’ll let you guys have a play with it first before I go too public with it! Let me know if you have any issues.

1 Like

Hey Rory, bad news…

Lots of issues, not sure where to start. Most notable, cabbage lite doesn’t seem to be loading anything properly, I end up with a small window (prob ~100x100 or so) with the cabbage symbol on each project. This includes trying examples (tested with AutopanTremolo.csd and Powershape.csd)

The sublime build output window displays this error, not sure if it’s useful:

2019-03-22 18:37:54.076 Cabbagelite[37189:193977] Error loading /Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter:  dlopen(/Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter, 262): Library not loaded: /System/Library/Frameworks/Jackmp.framework/Versions/A/Jackmp
  Referenced from: /Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter
  Reason: image not found
2019-03-22 18:37:54.076 Cabbagelite[37189:193977] Cannot find function pointer New_JackRouterPlugIn for factory 7CB18864-927D-48B5-904C-CCFBCFBC7ADD in CFBundle/CFPlugIn 0x7fe0374315e0 </Library/Audio/Plug-Ins/HAL/JackRouter.plugin> (bundle, not loaded)

I’m also having issues loading some of my more “complex” projects in the main cabbage app, but I suspect it has something to do with macros changing behavior, any ideas? It seems like imported widgets that use macros to define combobox values are causing the problem… but I’m not sure yet. If cabbage lite were working I’d probably have an easier time diagnosing it by myself, so this is definitely something that can wait if you don’t have any immediate suggestions about it.

For now I’ve backed up to the last working version I have, and everything seems to be back to normal for me.

Thanks I’ll take a look. You always seem to push it hard in various directions! I’ll assume it’s running ok for the general public…

I’ve heard that before :wink: I’m more than willing to send you an example zip if you like, but I think figuring out the cabbage lite issue would be best first. If I can get the examples loading in that, then I can at least trouble shoot from there.

I did a little more A|B comparisons… it seems that some of my instruments didn’t work in the old version if loaded into the main cabbage app, but worked ok in cabbage lite. Was there a discrepancy between the two that got “fixed”?

I’m testing with: CabbageOSXInstaller-3.5.19.pkg - 981965ed40cd6a366979849b4c52477b
Using the packaged csound version with each cabbage install
OSX: 10.13.4

Caveat: 3.5.19 is my download date, not the release date. If it helps, I believe it was linked from this thread: No waveform display

If there’s anything else useful I can provide, let me know!

I did a little more testing tonight. The good news is, it looks like CabbageLite IS working, sort of. The bad news is a regression snuck in, or a new bug masquerading as an old. Launching lite with a filename as a command line argument no longer seems to be working. But if I manually load a file from the menu, it seems to work perfectly.

This gave me a hint as to my other problem. I immediately noticed the new “theme” for buttons, and realized Cabbage Full wasn’t using them when I had tried. So it seems that I have more than one version of Cabbage installed, but I’m not sure where the second one is. Launching from the command line with a specific path launches the newest version, but launching from spotlight gives me a ~2 year old version hiding about somewhere. When properly launching the new version, I don’t seem to have the combobox problem I mentioned.

Sorry for the red herring, hope it didn’t cause too much headache looking for the problems. It’s so rare I use the full version that if Lite hadn’t stopped working I may not have noticed at all!

Now I’m off to find this stale cabbage hijacking the spotlight :wink:

That’s Ok. No problems. I’m always happy when things resolve themselves. I’ll look into the CabbageLite loading problem at startup. I did change something there. Must have screwed things up. Are the new icons not showing for you in the newest Cabbage? Darn it. I had to package it myself, I may have messed it up somehow. Friday evening blues.

If you mean the system wide icon for the app, it is indeed missing on the main cabbage app, but cabbage lite appears normal. Once launched, everything in the app seems about as I’d expect.

That’s odd, thanks for the report. I’ll look into this week, an the Cabbage Lite issues too.

Always glad to help if I can. I really like the new flat look for both buttons and (if I’m not mistaken) rsliders, and will play with those a little more today… but I’ll probably be stepping back to the last version since this issue with c-lite really slows down my work flow.

Please do let me know if/when there’s a new lite build, I’ll be glad to test it out and make sure it looks good.

Hi @t_grey, I’m just wondering if you’ve used the export command line option for CabbageLite at all? Calling the following brings up a save dialog:

CabbageLite --export-VSTi nameOfCsdFile.csd

I would expect it to simply create a plugin call nameOfCsdFile.vst. I would like to update it but I will look for a work around if it breaks your usage.

I haven’t exported anything in a really long time… and definitely not from the CLI. I don’t think I even know that was an option!

My DAW machine died a while back, so I’ve just been writing code with the hope of one day needing it again.
I’ll see if I can drop reaper on here and give it some testing tonight.

No stress. I don’t think many people knew about that option. It just seemed odd, but I can also see how it might be useful if using 3rd party editors as you do.

For sure! This is a good trick, I’ll see if I can add it as a build target in Sublime to make things even easier for me.

That said, it does not appear to be working either at the moment. It does appear to get further in the loading process with the requested file than normal c-lite loading from the CLI… I can see macros and ftables loading in the background of the console, but it seems to stop short of actually exporting, with the error message:

/Users/tgrey/bin/CabbageLite/Contents/CabbagePluginSynth.vst cannot be found? It should be in the Cabbage root folder

I guessed that this has to do with me using symlink in my ~/bin dir that leads to the installed app:
$ ls -al which CabbageLite
lrwxr-xr-x 1 tgrey staff 56 Jan 20 2018 /Users/tgrey/bin/CabbageLite -> /Applications/

So I tried running it with a direct call to the installed app, and received a new message:
The plugin ID identifier in /Users/tgrey/csound/cabbage/examples/Effects/Modulation/Flanger.csd is empty, or the plugin identifier string contains a typo. Certain hosts may not recognise your plugin. Please use a unique ID for each plugin.

It does create a .vst file in the directory, but it’s timestamped 12.27.2017 and is only 96B in size. I didn’t try loading it into reaper, but I wouldn’t have very high hopes that it would work.

Sorry it took so long, hopefully that’s helpful!

I had forgotten that .vst files are directories in OSX, so I re-installed reaper and gave it a check. It looks like it is working when calling the app directly, regardless of the error.

Not sure why the difference when using a symlink tho, that still fails to generate a file(dir).

Btw are you using the latest beta, or the latest official release? You can grab latest dev builds for OSX at the lines provided here. I fixed the colour issue and loading CabbageLite with a file from the command line. Still needs testing.

I was using the official release version from 3.22.19.

I haven’t seen or used this new build system yet, so I don’t know quite where to go with it yet… I’ll take a look.

Ok, if I understand this correctly… I grabbed from: #20190328.1

Launching CabbageLite with a filename still does not appear to be working. The button outline color does appear to be fixed.

Weird. It works fine for me when I run it in the debugger, but not in a release build. Sorry about that. I’ll try to get it sorted.

This issue just got weirder. I grabbed the freshest build, and thought this bug was still present… but it seems like it’s only happening when I have sublime attempting to “build” with cabbagelite. If I manually call it from a CLI, it appears to be fixed.

This is new, previously it didn’t work either way. Something must be screwy on my end, so I’ll keep poking around at it.

AHA! I think I’ve got this figured out!

It looks like CabbageLite fails to open a file argument form the CLI if it’s wrapped in single or double quotes.