Cabbage Logo
Back to Cabbage Site

Fresh install, libfluidsynth-2.dll and python27.dll missing

Just installed cabbage 2.0.03, first time ever on windows 8.1. I loaded some examples and when I press play, I receive these 2 errors on every example: libfluidsynth-2.dll is missing from your computer, and then same error for python27.dll.

Examples seem to work after I “OK” the errors, but I’m not sure if it performance as expected.

Any hints on how to fix this?

I just came across this myself today. The easiest fix, until I get around to updating the package is to install Csound from here. Disable the install Python checkbox during install. But if you still get a Python error, go to the “C:\Program Files\Csound6_x64\plugins” folder and rename the py.dll to something else. That will fix that particular problem.

I will try to get a new release up soon.

Thanks! That fixed it for now, had to rename py.dll as well.

Also, this is probably unrelated, but I noticed an issue with some of the examples: UI is not refreshing when you press play at first. This is the case with TR-808 for example and some others too (303, soundwarp among those I tried).

The sound is working but sequencer lights are not blinking and selected drum pads are not updated while you switch between types of drums. If you [x] close the UI, and press “show plugin editor” icon couple of times, UI appears as expected, with blinking sequencer and updates pads while navigating through drum types.

The GUI issue is something others have reported too, but I can’t recreate it. There seems to be some redrawing problems. Also, can you try this, can you add a slider to the instrument. Then in edit-mode, try updating the slider’s channel in the GUI properties, hit enter and see if the code updates. This seems to be broken for some reason, but only on certain computer. If you can, can you try choosing a different graphics card, if you have the choice. I’m starting to think it’s either a driver issue, or a recent Windows update that’s causing the problem. On my relatively old windows laptop I can’t recreate the issues. And they don’t present on OSX or Windows. :rage:

Ah, yes, confirmed, code is not updated if I edit slider’s channel in properties.

I’m also on laptop with GeForce GTX 850M graphics card, I switched to integrated Intel HD Graphics 4600 – the behavior is identical.

Arggh. Can you check what version of Win10 you’re using? I’m on 17134.285?

[edit] can you try this binary. Just rename your current cabbage.exe and run this one instead. It should use an OpenGL renderer. I really hope this works. This looks like a very sinister issue…

I’m actually on windows 8.1, Version 6.3.9600 Build 9600. The link leads to a Dropbox folder but I think the file you meant was, if it’s correct one – then it gave me error: MSVCP140D.dll missing :confused: and it does not start afterwards. Quest continues :slight_smile:

Sorry, can you try this one?

It’s a full blown installer. If you rename your current .exe you can install over the previous install.

Still no luck, both with interface redraw and channel update.

This is tricky. I will need to find a PC that I can recreate the problem with. Oddly enough, I think version 2.00 doesn’t have the same problems. What worries me about that is it uses an older version of JUCE. So perhaps something is amiss with the latest release of JUCE, although I’m surprised I’ve not heard anyone else mention it on the JUCE forums.

Hey @emir.more, would you mind seeing if running the app in compatibility mode makes any difference? IT have said they can loan me a PC so I hope to get to the bottom of this soon, well, as soon as they can source me a PC :wink:

Hey! Glad you’re still on it :slight_smile:

Testing under windows 7 and Vista compatibility mode showed no difference, bummer

Bummer is right. Did you try this version? If it doesn’t present any issues then I can at least say it’s an issue inly since I updated JUCE.

Yep! Confirmed, 2.0 works just fine, UI redraws and slider’s channel property updates the code.

At least this gives those Windows users a fall-back option until I can get this sorted. I’ve not noticed any issues with the exported plugins. They all seem to work fine in the latest version.

Hi @emir.more, can you try this one:
My machine doesn’t show the problems yours does, so I can’t test it. Would you mind?

I just tried on a machine here and it’ still not right. No crashed any more, but it’s still problematic. I’m getting close.

Yep, tried it, same issues present. I also tried it on a virtual machine with win 7 on same hardware, and it works without issues, not sure if it’s valuable info though :slight_smile:

Thanks for testing. It’s a tricky one. I really haven’t been able to identify what is causing the problem. I hope to take another look at it today. I’ll keep you posted.

Hi @emir.more, any chance you could try this? Just rename your existing Cabbage.exe and drop this one in its place. Many things don’t work in this build, don’t worry about that. I’m just hoping the edit mode problems are gone. If you get a chance to try it out before Monday let me know. Otherwise I can test myself then.