Cabbage Logo
Back to Cabbage Site

Help in pc

so like i mentioned before i bought a pc to do the pc version of my proyects, today i decided to try again as i have some question answered to fix some issues, so i take my project frommy mac THE WHOLE PROYECT FOLDER and copied & paste in my pc desktop, i open the c sound file from there, it look good so far, every art,button its there, but when im going to load the sounds it goes to the library and do everything like its gonna load but it doesnt,

i look at the warnings and i see this: error: syntax error, unexpected T_IDENT, expecting T_OPCODE or T_FUNCTION or ‘,’ or ‘=’ (token “directory”) from file C:\Users\wepaa\Desktop\mamboteo\mamboteo 3pc.csd (1)

im trying to fix it on the load button script but i got no idea, i try several codes but im missing something

this is the line of the button file, the last code i tried : filebutton bounds(196, 922, 50, 27) channel(“sampleFolderButton”), mode(“directory”), (’=*, C:\Users\wepaa\Desktop\mamboteo\Samples) colour:0(0, 0, 0, 0) colour:1(0, 255, 0, 0) alpha(0)

sorry this pc have the control+v in some other command it does let me copy paste from shortcuts, im learnimg this pc.

the folder its on my desktop, what should be the right code to add?

This is because there are errors in your code. You have two choices,

  1. attach your .csd file so we can look at it, which is what I ask you every single time you post something to this forum…

  2. work away on it on your won and hope you find the solution.

I’m happy to help, but I’m growing tired of having to repeatedly ask you to post or attach your code over and over and over and over again… :confounded:

JMDrum_Module-3_final.csd (47.4 KB)

I don’t know what’s going on here, but I wanted to mention that by removing “sr = 44100” from the file, the sample rate will automatically be set the same as in the host you are using the plugin.

thanx i did that now, i always work in 48.
other thing, just now i noticed when i downloaded roy live sampler and opened in my recent cabbage pro version on my mac it does dont show buttons or sliders, i decided to go to the first mac version i got 2.5.37 and it shows and play perfect, so that got me thinking it might be something between this old script from the .csd file i upload and the new fixes on cabbage way of scripting some stuff ( i hope u understand what i mean), i will try to upload the old pro version i got for pc to verify there,

error: syntax error, unexpected T_IDENT, expecting T_OPCODE or T_FUNCTION or ‘,’ or ‘=’ (token “directory”) from file string (1)

that error show in any cabbage version in my pc, im understanding i need to add 1 of these ‘,’ or ‘=’ ,somewhere in that filebutton line, i just can get it done.

Thanks for posting. This open fine for me here. I see no errors when I hit the play button? :thinking:

in my mac no errors, but in my pc it does, i saved straight to the pc/ program files/ vst folder and opens perfect but does not load sounds, i saved in all cabbage versions, i also saved other vst that opened like a little square and now show the way it supose to be but no sound also , i also save that one straight to the program files/vst folder, not to the vst folder just for see what happened, so it might be something that im seeing like this : ( ._ ) before some files in my pc that may be causing errors?

You tried a straight export from Cabbage or an example instrument? If they load in a DAW they should make sounds. Do they work in the Cabbage IDE? Maybe you could make a short screencast and share a link? Just record the exact steps you are taking with an example that comes with Cabbage. You can use OBS, it’s a free download. The file will be too big to upload here, but you can using google drive, dropbox, or onedrive to share it?

so i finaly get it working perfect , so i noticed in the .wav files and other stuff in the plugin folder i transfer from mac, almost al files have this: ( ._ ) a dot and a underscore in the begining of each file, so cabbage cant see those files because of that , and / or also when .csd file was saved to the folder wont recognize those files, it also make a duplicate files, 1 with the error and one original, as soon i erased the ones with the error everything start working,
what could make that happen when transferimg from mac to pc?

That’s odd, I’ve not seen that before. Maybe there are some Mac users here who might be able to offer some insight? You can use Reaper to quickly rename all the files if you like. Under File -> batch Convertor. But how are you transferring the files over? I usually dump files into my OneDrive or DropBox folder and then pick them up on my other machines. Are you transferring them with a USB drive?

im just using the same extrenal hd i use in the mac, im suspicious maybe is a virus on files in that hd, but because mac uses image it cant not see the files with pc virus, long tine a go a pc i had got a virus and i could not open anything , i found a program called “file scavanger” and it show me that the virus changed the name of the files, so the pc cant open them, i had to exactly rename the folders back so i can open the folders and then fix all files too,and it did something similar before the folder name and the file names, thank you and the others for your help.

one time my mac freeze saving something in that hd, and i had to manually shut it down, so when that happen in mac its common that the external hard drive dissapear, mac dont find it again, the fix is to connect it to pc and the pc will see tthe problem and fix the hd, and maybe my friend pc had a virus.

I rarely transfer file using an external HD. I prefer cloud based solutions for swapping things around.