Cabbage Logo
Back to Cabbage Site

How do I prevent GUI popping up whenever I save?

Whenever I push ctrl-s to regularly save my work the GUI for my instrument pops up in the middle of the screen, even if I closed it earlier, and repositions itself from my other monitor even if I moved it earlier.

How do I make it stay closed unless I run the code please? It’s so annoying.

Disable the ‘Always show plugin on top’ in the settings windows. It’s one of those features that really divides user opinions!

Thanks, but that setting doesn’t help. I see the problem is that the shortcut key for “save” and for “build instrument” are both ctrl-s. That’s a bit odd. In most languages build is F5 or ctrl-B or something, not save. I save all the time.

Yeah, save and build are the same thing in this case. When you save a file to disk, Cabbage automatically updates according to the changes made. In over 10 years of developing this software no one has ever reported an issue with this, but I can add an option to stop the plugin window from appearing when you save a file? You’ll have to leave it with me as I’m currently bogged down with other things. But I’ll add it to the list.