Cabbage Logo
Back to Cabbage Site

How to hide the plugin GUI right panel

Ok, I think the problem is that in the development branch, some folders are changed. My mods required a change to the file PluginWindow.h that was here:


but in the development branch that file is in another path:


That means there will be problems when you merge develop into master branch…

Lave it with me, I’ll update the dev branch now with those changes…

On my local copy I already recreated my previous mods in the current PluginWindow.h of the develop branch (+ the fix for the CabbageEffectNam titlebar in another file) and now they work. If you want I can make a PR with the mods.

P.S.: I noticed that in the develop branch the Cabbage patcher is different from before. It has a white background and has a virtual keyboard on the bottom and the window titlebar is completely black.

Yes please, that would be simpler. If you add the icons and icon folder too to the I can sort out those path issues.

Great, just pulled those changes in now. But the toolbar factory code is not updated with your changes? Can you push those through also?

I’m working on them now. :wink:

PR for you. :slight_smile:

I noticed some other things in the develop branch:

  • the start/stop audiograph button doesn’t stop csound;
  • the cabbage patcher is much different from before.

Can you give them a look?

I have to add a way of starting/stopping the graph. I will also add hooks for users to change the way the patcher looks. I set it to white last night just to test something. But it’s best the user can select this themselves.

Just merged that last PR. You should probably send on your settings file too so I can recreate your entire look.

In this commit I already changed the default colours in the CabbageSettings.cpp file, so when you have no cabbage settings file (or you delete it), it should automatically create my new colours scheme. :wink:

P.S.: I don’t know on Mac, but on Windows the settings file is in:

Nice. I hadn’t thought of that! My next job is to set up custom folders and add those new colour IDs. I’ll let you know when that’s pushed through.

This is done now. Read the git commit for details. All of these colours and custom directory can be set from the settings dialogue. But first make sure to put the icons folder into the same folder as Cabbage.exe

Nice! But now Cabbage starts with the button togglePlay (the last icon on the right, above the filetab) already pressed and if you click on it it doesn’t change its state and happens nothing.

Other little things:

  • The new File Tab Bar colour settings doesn’t work.
  • The MenuBar Text colour settings doesn’t work.

I’m not sure menu bar text ever worked. The File Tab Bar menu works now. I need to look into another bug now, but I’ll return to this stuff later today.

I fixed the MenuBar Text colour setting. Now works. I fixed an error in the pathname of the TogglePlay button icon too, so now it works (but works just the icon state swapping… The audiograph stopping is not working yet… This is to you to make it work, being that it depends from your changes on the audiograph code ;)).
PR sent.

EDIT: in the Settings, the path for custom icons could not be saved. Fixed this too.

1 Like

I made some changes to make the Property Panel button ‘X’ position and appearance more consistent with the new modern theme, and to make it auto-change its colours based on the user custom settings (to make the ‘X’ always visible with any colours combination).

Note that in my version the ‘X’ never overlaps with the property fields.

Then, I fixed the “Property Panel Background” setting that didn’t work (you had to change the “Console - Outline” colour to set the panel background).

I noticed that you could not change the colour of the Property Panel section titles (they were always black), so I made them auto-adjust their colour (and that of the little arrow beside them) based on the panel background colour the user set.

I noticed that if you close the Property Panel with the ‘X’ button, then, if you click again on the same widget that had focus when you closed the panel before, the Property Panel will not appear and, if it was open, it disappears! I fixed this.

I noticed that from the settings you cannot change the highlight “background” colour for the output console text, so I modded the code to use the “CabbageColourIds::selectTextBackground” for it. And I made it so that the colour of the highlighted text is auto-adjusted to make it always visible with any custom colour combination.

If you want I can make a PR.

P.S.: On my notebook I noticed that using the code of the develop branch, when you move the Cabbage patcher window, the PC struggles a little to move it. The Cabbage patcher of the master branch is faster.

Make the PR :wink: The new patcher is a child of the main application. I just did it this way to simplify the communication between the two. I can change it. It’s on my list of things to do.

Added some other little fixes and made the PR. :wink:

P.S.: I created a PropertyPanelLookAndFeel class for the Property Panel component, so that future mods on its look should be simpler to make. And I created a FlatButtonLookAndFeel class that I used to change the X button appearance but it can be used in the future to make super-simple-flat buttons.

P.S.2: When you close the Plugin Edit Gui Window, but the Property Panel was open, I think in this case it should be closed the Property Panel too, being that its changes work only if the Plugin Edit Gui window is open… How can we do that?

Give me a sec, I’ll add that now.

You can add something like to the CabbageMainComponent::setEditMode() method:

if (enable == false) { propertyPanel->setVisible(false); resized(); }