Cabbage Logo
Back to Cabbage Site

IDE crash on MacOSX Sierra

When I’m trying to start (hit Play) for instrument and effect in the same time IDE just collapse. Where can I find crash logs to post here?

Can you post the two instruments, or does this happen with the examples?

Hi @yourevilempire, can you confirm that this behaviour happens with examples distributed with Cabbage, or just with your own files?

To add I get crashes on Sierra, not High Sierra!

Latest build from 2/5/2019 I believe. Problems I have are:

  • Immediate crash on clicking Open icon
  • Starting a plugin, stopping then starting again causes immediate crash
  • I can’t start any of the Examples - says I need to save a new version

Weird as I installed the same on my laptop running High Sierra, an having none of the problems.

Is this sounding like some corrupt preferences that need trashing? I thought I tried that but still issues…maybe I missed something.

If you get an immediate crash when opening a plugin, how can you then start a plugin?

My bad. I’m just building a new version now, I’ll upload when it’s done.

I’m not sure what’s going on. Can you nuke the settings file and see if that helps? I can’t check that OS because I’m already on High Seirra…

p.s. Can you check that the audio device is set up correctly in your audio settings?

sorry I’ll be clearer! playing the code in the tab, then stopping, then playing :slight_smile: all within Cabbage IDE

which settings file is that, not the ones in /Library/Preferences?


Yeah that one, simply delete it and see if that makes any difference. I have an image of OSX on a VM, I’m going to launch it now, but I’m not sure whether is high or low Sierra…


So that VM image I have is 10.12 and it works fine for me. I simply installed the latest version, created a new instrument, hit save, and I could play away fine without any crashes. If you continue to have issues after you delete the preferences file, re-run Cabbage, and send me the new pref file, maybe we can see something in that.

Downloaded and install the latest build as of today

OK it was when there were no tabs loaded, so it shows the Cabbage logo on load, nothing more, then when clicking the Open icon it crashes instantly.

Time Awake Since Boot: 13000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  JUCE Message Thread  Dispatch queue:

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x00000000000000a8
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0xa8:
    __TEXT                 00000001002ea000-0000000100cf1000 [ 10.0M] r-x/rwx SM=COW  /Applications/

Thread 0 Crashed:: JUCE Message Thread  Dispatch queue:
0   com.cabbageaudio.cabbage      	0x0000000100716a0a juce::Component::isShowing() const + 10
1   com.cabbageaudio.cabbage      	0x000000010073e26c juce::Component::grabFocusInternal(juce::Component::FocusChangeType, bool) + 28
2   com.cabbageaudio.cabbage      	0x00000001002f395c CabbageMainComponent::buttonClicked(juce::Button*) + 140
3   com.cabbageaudio.cabbage      	0x000000010073f527 juce::Button::sendClickMessage(juce::ModifierKeys const&) + 327
4   com.cabbageaudio.cabbage      	0x000000010073f10d juce::Button::internalClickCallback(juce::ModifierKeys const&) + 157
5   com.cabbageaudio.cabbage      	0x000000010078833f juce::MouseInputSourceInternal::setButtons(juce::Point<float>, juce::Time, juce::ModifierKeys) + 687
6   com.cabbageaudio.cabbage      	0x0000000100791813 juce::ComponentPeer::handleMouseEvent(juce::MouseInputSource::InputSourceType, juce::Point<float>, juce::ModifierKeys, float, float, long long, juce::PenDetails, int) + 531
7   com.cabbageaudio.cabbage      	0x000000010079154c juce::NSViewComponentPeer::sendMouseEvent(NSEvent*) + 284
8   com.cabbageaudio.cabbage      	0x000000010078beb5 juce::JuceNSViewClass::mouseUp(objc_object*, objc_selector*, NSEvent*) + 165
9              	0x00007fff8b7448de -[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 1544
10              	0x00007fff8b743f0a -[NSWindow(NSEventRouting) sendEvent:] + 541
11              	0x00007fff8b5c8681 -[NSApplication(NSEvent) sendEvent:] + 1145
12              	0x00007fff8ae43427 -[NSApplication run] + 1002
13  com.cabbageaudio.cabbage      	0x00000001005456ec main + 348
14  libdyld.dylib                 	0x00007fffa2ae9235 start + 1

this is the crash dump. In fact clicking the save button too causes a crash. Haven’t tried the others

Can report the examples working :raised_hands:


Great, I can recreate that problem. Leave it with me. Ill get a fix up shortly…

[edit] fixed, I’ll update the release in a half hour or so once all packages have been rebuilt. Thanks for reporting this issue. I could have been using Cabbage for weeks without having ever encountered it!

no problem at all! thanks for fixing it

Can you try the latest package from the current release? Should be good to go now :wink: