Cabbage Logo
Back to Cabbage Site

Knob n sliders filmstrip

alex filmstrip test.csd (3.5 KB)

hi, so im practicing on adding filmstrip knobs, sliders, i used the knobman filmstrip example on cabbage to practice, i load the knobs from de knobman app mentioned on the description of the example, i load them but the just move up and down and i can see the strip instead of see it go round,( using the original script from the example) so i decided to all post here , i try every code i saw,still see it like that, i also render the vst an opened in ableton to see if converted will work, but it looks the same, try filmstrip.xml on from caption line , try adding ( “slider name”,120,"vertical) on the image bounds, still not working, i add these images into the project folder,i verify various times the script for errors on my part, so what im missing

You should use the latest beta version of Cabbage, there is much better support for filmstrips with that.
Click the drop link here and then download the installers. After you install the latest version, open the new KnobManFilmStrip.csd file. It’s much easier to use the new filmstrip code than the version you are working with :wink:

HI, still the same,no rotation just up and down, i updated ,not working on filmstrip knobman , knobman 2 examples, stil scrolling, its a correct way to send it from knobman page ( a specific rendering, ? ),its a specific code i need to add? i also tried every code i saw on this thread, no results, the vumeter moves perfect,exactly like the example but the knobs not

Are you saying that the current knobman example doesn’t work? I tested it last week and it was fine. Either way, there is little anyone can do unless you attach the code that isn’t working for you. Along with the filmstrip pngs :+1:

Btw, I just tried one of these and it worked fine. Just make sure you have the right amount of frames. There are 90 in the first image, but I couldn’t guess correctly on the others.

your filmstrip examples work great, it got to be me on this side, i will try again with the right amount of frames, thanx

just a question: before i could save my vst as a synth, in this version i noticed that i have to saved as a effect, which is thre right way to save a vst? as effect or as synth?

You should save as an effect if it will be an effect, and a synth if it will be a synth. :+1:

this is happening on my imac, on beta upgrade of cabbage, i try to change buttons image but it goes back to the original, also with other widgets, i uninstalled and use the previous version and works ok, im planing to uninstall and then install the beta version, maybe that will fix the issue,i let you know,thanx

You should add images via the code in the cabbage section. It looks like there is an issue with adding them via the GUI editor. You’ll find all the identifiers you need in the slider doc page:

As you can see on that list, image() is not a valid identifier for an rslider. But I have to put my hand up and accept that the GUI editor needs a little updating. I will take a look at that this week and see if I can add filmStrip identifiers to it.

I’ve updated this now so that the GUI properties panel contains a filmstrip field for sliders. As you can see from the clip below, if you don’t put in the correct number of frames you get odd behaviour.