Cabbage Logo
Back to Cabbage Site

Lava Lamp Example crashing

Hey there, I can’t run the Lava Lamp example (Examples/FunAndGames/sonic_lava_lamp).
I remember that it was working in the past.
The log from the past (it has the date of tomorrow one year ago :joy:) says it is looking for files in Iain computer:

Cabbage Log..
Log started: 14 Mar 2023 7:15:55am

WARNING: could not open library '/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/librtjack.dylib' (-1)
WARNING: could not open library '/Users/iainmccurdy/Library/csound/6.0/plugins64/libimage.dylib' (-1)
WARNING: could not open library '/Users/iainmccurdy/Library/csound/6.0/plugins64/libfaustcsound.dylib' (-1)
WARNING: could not open library '/Users/iainmccurdy/Library/csound/6.0/plugins64/libpng16.16.dylib' (-1)
WARNING: could not open library '/Users/iainmccurdy/Library/csound/6.0/plugins64/libpy3.9.dylib' (-1)
WARNING: could not open library '/Users/iainmccurdy/Library/csound/6.0/plugins64/libchua.dylib' (-1)
UnifiedCSD:  /Users/iainmccurdy/Documents/
rtaudio: PortAudio module enabled ...
using callback interface
--Csound version 6.18 (double samples) Nov  6 2022
[commit: 7b7661e9a902473e30e98983bc2983f74e37f838]
sr = 44100.0, kr = 1378.125, ksmps = 32
0dBFS level = 1.0, A4 tuning = 440.0
audio buffered in 1024 sample-frame blocks
Cabbage version:2.9.22

Resetting csound ...
csound = 0x0x0

No rush on this just wanted to report!
(Cabbage version in the log is wrong, it is 2.9.171, I’m on a Silicon Mac)

EDIT: Ok so apparently the above is not my log, but probably Iain’s? It can be found next to the sonic_lava_lamp.csd in the Cabbage Examples/FunAndGames folder. The crash is real though :smiley:

Corrct, I’ll remove that log file and take a look at this when I get a chance. :+1:

I just tried with the latest build, 2.9.198, and I didn’t have any issues. Are you running it in the IDE or as a plugin?

Just playing the csd in Cabbage makes Cabbage crash after a short beep, I have latest Csound (6.18.1).
Let me try grabbing the latest Cabbage build!
EDIT: just grabbed the latest artifact and after installing Cabbage doesn’t run at all
image it says it can be damaged or incomplete

Edit: I tried older builds but they are not working. The first working build on Silicon Macs (haven’t tried them all) is 2.9.181

And does the lava lamp example run with 2.9.81?

nope same crash

Ok, I’m going to check here on MacOS.

1 Like

It’s working here for me and I think the latest build is going Ok, can you test it when it’s done and let me know?

1 Like

I tried this build and Cabbage can’t run at all

Lava lamp example runs again in version 2.9.201, thanks!

1 Like