Cabbage Logo
Back to Cabbage Site

Linux build reports missing library

i am on debian 11, and built the linux package. this worked, but once i do /usr/bin/Cabbage, i get these error messages:
/usr/bin/Cabbage: /lib/x86_64-linux-gnu/ version GLIBCXX_3.4.30' not found (required by /usr/bin/Cabbage) /usr/bin/Cabbage: /lib/x86_64-linux-gnu/ version GLIBCXX_3.4.29’ not found (required by /usr/bin/Cabbage)
/usr/bin/Cabbage: /lib/x86_64-linux-gnu/ version GLIBC_2.35' not found (required by /usr/bin/Cabbage) /usr/bin/Cabbage: /lib/x86_64-linux-gnu/ version GLIBC_2.32’ not found (required by /usr/bin/Cabbage)
/usr/bin/Cabbage: /lib/x86_64-linux-gnu/ version GLIBC_2.34' not found (required by /usr/bin/Cabbage) /usr/bin/Cabbage: /lib/x86_64-linux-gnu/ version GLIBC_2.33’ not found (required by /usr/bin/Cabbage)

i also tried downloading the sources and run python --config=Release --installLinuxDeps=True but this did not help.

anyone knows what is missing here? thanks -

ok i found the reason:
strings /usr/lib/x86_64-linux-gnu/ | grep GLIBCXX
reports the the most recent version is GLIBCXX_3.4.28, but required is obviously 3.4.29.

i installed Cabbage 2.8 instead, and this works.

I think you will need to build yourself to get the latest. What was the output of:

python --config=Release --installLinuxDeps=True

It should create a folder in the root dir called cabbageInstall that should contain all the binaries. Can you post the output of the build, and also check that dir when the build is finished. It could be that the build is fine, but you haven’t installed it?