I just did my first tests with the meter widgets. These could definitely come in handy! A few very minor observations however:
It seems like the meter color names are logically reversed. metercolour:0 represents the color when the meter is fully on, and metercolour:2 represent the colors approaching off. This seems unintuitive, and I feel reversed would seem more consistent with buttons where colour:0 is their off state, and colour:1 is on.
Similarly, overlaycolour seems like it may be better suited to be called underlaycolour? Or maybe just colour, since the meter uses metercolour?
Either way, not really big issues… just some thoughts. Especially since this is a “newish” widget, if renaming were to happen, better now than later!