Cabbage Logo
Back to Cabbage Site

MIDI input notes sticking - also forum user icons?

hey Rory - scott here - it’s been a fair bit of time! hope all is well with you…

i fired up Cabbage and trying the various synths again and noticing that with live MIDI input notes are sticking quite a lot, even for an older serial interface spec (MIDI). it’s also happening on the GUI keyboards as well, though. my ‘Mac’ has been updated to a macOS High Sierra and i’m on your latest release.

additionally i used a really simple demo script that came with the [csound6~] object i’m using in PD (i’m back to PD again). in PD this script works perfectly and is quite robust. i also opened this up in CsoundQt with absolutely no problems. so i think something must have changed on the MIDI input front because as it is it’s pretty much unusable for me. it might be the macOS version. i just tried 2.0 and had the exact same issue of sticking notes. i’m on 10.13.6 BTW

Ian’s synth demos as well as their onscreen keyboards also stick though not quite as often.

anyway any light you can shed here would be great. i’m investigating using a few of Ian’s instruments in PD using [csound6~], but not finding Cabbage to be a good testing area for this. i would love to just use VST plugins in PD but it seems on macOS that having the VST GUI and the audio in the same thread (which apparently is now required) is problematic and is still an issue needing to be solved.

PS - one other weird issue - seems like a lot of user icons in the forums are now coming up broken. not sure what’s up with that, but also happening in latest Firefox as well as Safari. mine’s fine. i wonder if it’s the automatic letter icons that aren’t rendering.

scott

Hi Scott, I’m also on 10.13.6 (Cabbage 2.1, about a month old) but I can’t produce stuck notes, no matter how hard I push it. This is tested in Cabbage standalone and running as a plugin using both the GUI keyboard and an external keyboard. The problem seems to be somewhere other than the MacOS version…

hi Iain! thanks for letting me know. i guess it means that maybe my install of Cabbage is somehow suspect? i have a Hackintosh but i don’t think it’s the hardware that is a problem as both PD and CsoundQt had no issues with it at all. is there a setup configuration that affects MIDI data maybe?

actually i do have a separate question outside of this, but it’s not a bug-like issue so i’ll post something in the Csound Noobs topic for that. meanwhile i’ll start in Safe Mode and see if there’s an extension that might be interfering, possibly.

scott

i did find one repeatable crash though. when playing back or not playing back a loaded script, clicking the controls icon on that script’s tab is an instant crash for me, but it’s so hard that it doesn’t even register as a crash. very strange…

aha - these are CsoundQt or non-Cabbage based scripts with no Cabbage GUI markup. that explains it. though it should probably give some sort of dialog saying there’s no GUI present rather than just quitting. i think it quit instead of crashing, actually. but it did so instantly.

scott

Good spot. It shouldn’t crash, even if they are no Cabbage .csd’s. I guess those controls could be disabled in these instances. Regarding sticking notes, I did make quite a few improvements to the MIDI handling code in recent versions. @T0NIT0RMX and I went through it pretty deeply and weeded out what we could. In the end it’s much more stable than it used to be. I can’t recreate any sticking notes, in the Cabbage IDE, or in a DAW. I"ll take another look in case I missed something.

okey doke. more research on my end of things. it looks like the MOTU Track16 audio interface driver, and specifically the MIDI portion of that driver, is the main cause of the sticking. switching to my Photon X25’s USB MIDI input even while using the Track 16 for audio was excellent, as was using the class compliant audio driver for the Photon and plugging in my AKAI LPK25.

disabling the Track 16 MIDI input and just leaving the other port also seems to work. it seems there was enough chatter coming from the Track 16’s MIDI input to interfere with any other MIDI device especially on the same USB bus. and i had disabled the Track 16 MIDI port in PD as well as CsoundQt. i guess you can mark it as solved! although still curious if you’re seeing broken generic user icons on the forum…

Thanks for reporting back on this. And I’m glad you found the root of the issue. Regarding the user forum, I’m not seeing any issues? Are you talking about the edit icons when composing a message?

I have the same problem, some notes off are not recognized when I use my Cakewalk UM-1G midi interface. On windows it’s worse: notes are playing that are not sent by the keyboard. What is also strange, is that in this case, the keyboard widget has the same problem when the interface is connected. When I use my Alesis Vortex keytar, there is no problem.

On CsoundQT, with the same .scd file (excepted options), these problems don’t occur.

I’m afraid to report I can’t recreate these problems. @TONITORMX and I did a lot of work on this over the summer and fixed a lot of issues regarding how MIDI is handled. Is it a particular .csd that is giving you issues? Also, can you test it as a plugin and see if the same problems persist when it is run in a DAW?

I don’t see how this is relevant, but that’s good to know :wink:

p.s. If there are any other users out there experiencing this problem please let me know. The more users out there that can recreate the problem the better and easier it will be for me to fix it.

Here’s a quick screencast of me trying my best on OSX to recreate this problem. I just can’t get a stuck note? The parts in the middle when things get silent is when I have the arpeggiator on at full speed. Still no problems.

Is it a particular .csd that is giving you issues?

I just used the default instrument created by the menu New Sound File /(new synth instrument)

The fact that the problem happens with one midi interface and not another has certainly to do with the driver of this interface. I will test this evening with a plugin.

Until now I often used this midi interface to record my electric piano in Reaper without any problem.

Cool. Let me know if your tests reveal anything I can use.

Well, I tested the instrument as a VSTi plugin inside Reaper, with the same midi interface: no problem everything works. I’m not surprised.

Nor am I. Reaper is such a well developed DAW; I have rarely ever experienced any issues with it.