Cabbage Logo
Back to Cabbage Site

Midi out stopped working?

Earlier, I’ve used to do midi out with the noteondur, and the options
-n -d -m0 -+rtmidi=NULL -Q0 -M0

I have this working in many plugins, but now if I re-export them with the latest Cabbage, I get no midi out.
Those exported with earlier Cabbage versions (not sure which version), they still work.

Is there a chance that anything has changed in the way midi out is handled?
Attaching my simplest test csd just for reference.

All best

midi_out_cabbage.csd (2.3 KB)

I’ll take a look tomorrow. I was recently working on some MIDI out plugins and they worked just fine.

[edit] I couldn’t wait. Seems to work fine for me here with the latest beta build.


Thanks for testing it. I did the same as you in Cabbage patcher, and it works there for me too. Although when I load the VST in Reaper, it does not produce midi out. This did work in previous Cabbage versions (same csd, worked earlier today, it was exported with an old Cabbage version. Then I re-exported it and it did not produce midi out anymore)

I’ll try tomorrow to get it working in Reaper, a student of mine just finished a MIDI based plugin for a recent project. He was using Live as a host, but had no problems getting things working. I’ll let you know.

Hi @Oeyvind I’m not having any issues in getting this instrument to run in Reaper. I just did a straight download/export and it works out of the box.

Maybe something is not right in Reaper?

p.s. excuse the audio quality - that’s nothing to do with Reaper or Cabbage!

Very strange indeed.
Here, I’ve loaded up an old compiled version of the same csd (named midi_out_cabbage) and a new compile with the current Cabbage verision (plugin named midi_test). Both on the same track, and routing the midi to track 2 like you did. I did not load a midi instrument on track 2, as we can see the yellow midi indicator. With the old plugin I get midi, with the new one I don’t. They both use the exact same csd.

Does it make sense for you to inspect the two dll files I have (old compile and new), I could send them to you if it makes sense.

I’m afraid I won’t be able to tell anything from looking at the dlls. Do you know the build number of the older version? if it’s not too old it should show the version number if you scan the plugins using pluginval. If I knew that I could look back through the source. You’re definitely exporting as a plugin synth?

Oh … ?? I did not export as a vst synth, but as an effect.
Now I tried exporting as a synth, and that produces midi out. Ah. Good!
There’s really no way I can be sure what I did earlier, months ago, maybe years. But, I know I have almost never used vst synths for anything as I usually have some kind of audio input. So, I am as sure as I can be that I did export as a vst effect and had midi out earlier. Does it seem impossible?

Yes, that’s it! The effect plugins no longer output MIDI. it’s a change that was mad at some point, for some reason, but I can’t recall off the top of my head why. I’ll take a look through the forum and get back to you…

The only mention of it I could find was from 2 years ago when I mention only synths can output MIDI, but I can’t find any reasoning for it. So I’ve triggered a new build now that should allow VST effects to output MIDI too. Sorry about that, I hope you didn’t lose too much time over it!

1 Like

Ah, good. Great that you could make it work again. Thank you so much!

Tested the new build and it works nicely!

1 Like