Cabbage Logo
Back to Cabbage Site

Plug-in from MacBook Pro to iphone

Happy to be here …
I would have a question right away:
is it possible to use on my smartphone (iPhone SE) in tandem with AUM, plug-ins created with Cabbage with MacBook Pro (macOS)?
Thanks for any reply,

I’m afraid not. It might be possible in the future with Apple moving to arm chips on all devices, but for now it is not possible.

Thanks Rory,
… But still some questions; maybe I’m off topic …?
I’m with MacBook Pro (Catalina 10.15) and re-installed Cabbage a few minutes ago - after a long time not using it, but …:

  1. after having opened an example of Jain MacCurdy (Multireverb.csd), after having given the Play I don’t hear any sound in the headphones (the mic is active) …
  2. if I try to Stop it doesn’t work, it stays in Play mode …

…am I doing something wrong?

Can you try the latest beta build? Click the installer link here and download an installer. I’m looking to do a new release soon, a lot has happened since 2.8!

ci provo…

I downloaded the application, but I don’t know if it has been overwritten to the previous one or not… anyway I downloaded the one you see in the image (about)

That’s the latest. And does it work Ok?

The example you mentioned works fine for me here…

I opened the app and loaded Jain’s MultiReverb.csd, but at Play the app closes; I tried several times … but it always closes …

What version of Csound are you using? Can you install the latest just to be sure?

the installed version of Csound is 6.16.2

I’m not sure what the problem might be. Have you installed Cabbage in the standard location? I’ve not had any other reports about this :thinking:

yes I installed Cabbage in the Application and the installation was successful …

Can you try some of the other examples? Do you get the same behaviour with each?

yes, I have the same behavior.
I tried with CsoundQt to launch some csd and this program also closes …
Maybe I’ll have to reinstall Csound, or just do a system reboot?

If the same thing is happening with CsoundQT it would lead me to think there is an issue with the Csound install. Can you run Csound Ok from the command line?

I tried what you tell me from inside CsoundQt with Run in Term, but it doesn’t even start …

I’d reinstall Csound, and try it from the command line to make sure it’s working. If so, then CsoundQT and Cabbage should work Ok.

Do you know if Csound 6.17 works on Catalina macOS 10.15?

I can’t think of any reason it would not. If there was an issue I think we would have heard about it on the mailing list? :thinking: