Cabbage Logo
Back to Cabbage Site

Plugin resizing

From @Gerbo in another thread:

How time flies @rorywalsh… I wish your health is the best and you recover soon from your hand :+1:. In my case, as you will remember, the sight told me Enough! :sunglasses: Which has forced me to put on the brakes.
The truth is that it has been a very rewarding experience due to the interaction that has occurred. Surely one of these days, I will return with a new project, because it is very tempting to work with this wonderful tool :wink:.

I decided to see the latest advances of Cabbage, realizing something… I observed that until version 2.9.73 resize works correctly (memorizes the resize percentage in the DAW, when closing and opening session). As of version 2.9.74 it is no longer possible until the latest build 2.9.106.
Is it possible that this has something to do with it?


Hi @Gerbo, I just tested this here and it seems to work fine for me. I’m using the plugin resizing example that comes with Cabbage.

Are you seeing different behaviour?

It is when saving and opening the session. Does not retain size adjustment.

you mean the size is not saved with the current session? Ok, I’ll take a look :slight_smile:


Fixed. New build triggered. :+1:

I have tried it on mac intel, and now it works fine. Thank you :+1:
I have also observed that the latest version 1.0.3 of pluginval is giving quite a few errors on Mac Intel. I’ll detail it to you shortly.
I don’t know if in Mi, M2 the test is correct. I don’t have a machine to test.

These are tests made with pluginval v1.0.3.
However, the plugins behave perfectly in the DAW.
pluginval test (18.9 KB)

1 Like

hi @gerbo, are these all tested with strictness level set to 10?

Yes @rorywalsh , to the maximum rigor (10)

1 Like

Hi @rorywalsh, I have noticed that the new presets in version 2.9.108 do not save the name when logging out and logging in. However, the plugin does appear with all the settings.
This happens as of version 2.9.74

can you give me a little more detail? I did do some internal work with the presets, so some things have changed. do they no longer work, or do they still work, but differently?

Of course :slightly_smiling_face:!
Any plugin up to version 2.9.73 behaves correctly and saves the preset name. As of v2.9.74 it does not save the preset name when the session is reopened.

With the previous preset system (NewPresets), I have had no problems. No customer reported anything strange in its operation.
Also the current “NewPresets” example reproduces the same error.

Thanks @Gerbo, I understand what you’re talking about now :+1: thanks for your patience. I’ll look for a fix.

1 Like

this should be fixed now @Gerbo. new build underway :+1:

Now it’s perfect @rorywalsh :+1:

  • The preset name is correctly loaded when opening the session
  • The resize is also memorized when opening the session.
1 Like

unrelated to this thread, but have you been able to load AUs in Logic with the latest builds of Cabbage? It’s the one DAW I no longer have, and I fear there might be an issue with it.

Works fine in Logic and Reaper on Intel Mac :+1:.
Anyway, I’m going to build this latest version of Cabbage 2.9.109, to check the “Stereo_Mono_Only=1” patch

Count on me for any proof you need :sweat_smile:.

I think the issue is with AUs on M1 macs. I need to look into it further but thanks as usual for the prompt feedback!

1 Like

Thanks to you @rorywalsh! Let’s see if there is any luck with those M1 :grinning:
Have a nice weekend!