Cabbage Logo
Back to Cabbage Site

Pre-release Cabbage 2 for testing - part 4

New binaries available…

See latest pre-release testing post…

As always, please try to break beta this in every way possible. Let me know how it goes. I think I’ve addressed most of the previously reported issues. If not, please let me know. I know that beta testing can be a frustrating phase of development for everyone, so thanks again for your patience!

[NOTE] This is still just the standalone editor for now…

Well, I found nothing incriminating. Everything I tested worked the way it should. I can see a good reduction in the editor lag that I was talking about earlier as well.

That’s great. I updated the JUCE source so hopefully that fixed it. I think it’s almost time to as exporting of plugins. I think most of the widgets are working just like they did, although the XY pad still needs some love!

I’ve updated the OSX link above to a version with plugin libraries. There are still some outstanding issues, as reported by @zappfinger , but it would be nice if people can try these out a little if they get a chance.

Hey Rory,

When do you think we can expect the first release of Cabbage 2? Is it wise if I ask students to install it or should I just stick to Cabbage 1 for the moment?

Stick to Cabbage 1 for now I think. I should have more time to work on this once the exams are over, mid-May or there abouts. I hope to have a full release some time after that.

couple of weird bugs in the latest version on a Mac (yosemite 10.10.5). in no particular order:

text source editor doesn’t update line numbers (tested in Studio and in Cabbage as well). you can scroll though text but line number will not update until you click on the window and resize.

in Cabbage Studio:
the X/Y pad on various synths is broken but the X and Y sliders can be manipulated in the sidebar at the top left.

on synths with presets, display of the selected preset gets immediately blanked out when selected. i seem to remember the earlier version of Cabbage Studio had this issue as well.

the hsboscil synth Mod.Shape menu does not appear to change waveform from the dropdown list. the controls in the upper left sidebar do change though.

in the ePad synth, all controls in the upper left corner do not work, but again they can be adjusted in the sidebar slider area.

hope this helps a bit,

I think perhaps you are referring to the current release of Cabbage 1.n, rather than Cabbage 2.n which is linked above. For more details look through the posts with ‘Pre-release Cabbage 2…’ in the heading. I’m reluctant to spend time on bugs in Cabbage 1 considering Cabbage 2 is available for testing.

ah. and you’re right as it appears i can’t run the latest preview linked there anyway since i have Yosemite and you need 10.11 or higher. guess it’s time to update the OS. which since i have a hackintosh will be a non-trivial task. disregard my complaints then.


I set the minimal build to is 10.8? If it says it need 10.11 then it’s my fault. I won’t be able to update it for a fortnight though as I’m away from my Mac till then. Apologies for this.

oh well. my loss then. no worries - i can work with this version.