Cabbage Logo
Back to Cabbage Site

Pre-release Cabbage 2 for testing - part 5

Well, I don’t have the mac with me now, but he was using El Capitan (don’t know the exact version number). And the issue I was talking about is posted here : Custom GUI dont work when vst is loaded in Daw

Is there anything I can try? Reinstall Cabbage 1? The VST SDK is supplied with Cabbage 1 right?

Firstly, can you send me a simple example with custom GUI that didn’t work as a VST, I was sure this was fixed.

As for the second issue, this is trickier to solve but let’s keep trying. Can you send me an exported .vst bundle through Dropbox or wetransfer so I can try it out myself?

I’ve sent you a message with the links.

Also, my friend said he’s been getting the following console logs on both Cabbage1 and 2:

WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libjacko.dylib’ (-1)
WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libjackTransport.dylib’ (-1)
WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/librtjack.dylib’ (-1)


Thanks. I’ll check out the link and get back to you. Those warnings are not a problem. They have something to do with Jack not being found on his system but as Jack is not needed to run Csound you can just ignore them.

Both of those .vst bundles load for me in both Live and Reaper but the version from Cabbage1 doesn’t show the custom GUI even when I place the files within the bundle (I think this is because the files are contained within a separate folder). But everything loads fine in version 2 when I place the Assets folder into the Contents folder of the Cabbage2 bundle (see screen grab).

Note however that neither if these plugins will actually work because they contains syntax errors. I can’t see why this would prevent a DAW from loading them, but it’s probably the first thing to look into. The errors I’m getting are related to ftgenonce?

Thanks for testing them out! I’m stumped that they are getting picked up on your machine. And as for the errors, this is a pretty old version of the plugin, he might have changed a couple of things as well.

I’m also stumped, but it looks like a problem on the local machine rather than Cabbage? I guess you should make sure he is adding the relevant VST paths to his DAW? In my experience, if they are not being seen it’s most likely because the DAW doesn’t know where to find them.

I checked this myself. I pointed the VST path correctly. Cabbage 1 vst’s were picked up, but not Cabbage 2’s. I was using AudioMulch by the way.

Hmm. I can’t see why one binary was picked up but not the other. I might download a demo of AudioMulch and see what’s going on. Do you have any other hosts on your machine that you could test with?

No, just Logic. But I might trying installing a Reaper trial when I get hold of it next.

You’re right. The version 2 plugins don’t open on AudioMulch. That’s odd. They are seen by every other host. I’ll see if I can figure out what’s going on.

It’s because AudioMulch is still i386 only. I’m quite surprised by this. I assumed it was 64bit. Anyhow, it’s a simple fix, and one that should be beneficial for all users who are running i386 apps. I will upload new binaries later. Thanks for your patience!

[edit] Turns out the simple fix is not so simple after all. I can build plugins that will run in AudioMulch, but the ones I do won’t run in any other host. The Universal binary builds I’m doing aren’t being picked up in AudioMulch. I don’t like where this is going, i.e, having to distributing 32bit plugins especially for users of AudioMuluch.

I think I’ve found a solution for this. I’ve updated the binaries can you take a look and see if they are Ok? They seem to work Ok for me. Finger crossed they will for you.

Thanks for looking into this! I’ll be meeting him tomorrow, I can test it tomorrow and let you know.

No luck here. I tried out the new binaries from the link on top. Still doesn’t work on AudioMulch. But I downloaded the Reaper64 trial. Works fine there, as expected.

I think I finally cracked it :wink: Can you try the link above once more. I just updated the binaries, and it’s working Ok for me here. I was just missing a few things in my build script.

Will let you know how that goes.

Here’s some strange behavior I found, in this release of Cabbage 2 for Windows. While defining macros for widgets, if only one attribute is defined, it works fine. If 2 or more attributes are defined, the first one isn’t getting picked up.

For example:
#define SliderMacro visible(0), trackercolour(159, 0, 0, 255)
rslider bounds(10, 40, 68, 50), $SliderMacro

The visible(0) is not getting picked up.

And more importantly, the ‘Edit Plugin GUI’ button is not working in this version.

That’s annoying. Thanks, I’ll look into this. I thought I had the GUI edit thing sorted.

Should be fixed now. Package updating as I type…

Great! And the vst’s are recognized by AudioMulch on Mac new.

I found another problem, on windows. But before that, how are the attributes within the tag parsed? Do they need to be comma separated or space separated? It works both ways, but I was wondering which one is better?
When I click on a widget in edit mode and change some parameters graphically, it will rewrite that line without commas. Also, when I toggle something (Active or visible), it’s not reflecting the correct value in the code, but just introduces a new comma character.

And the Macro problem is still persistent.