Cabbage Logo
Back to Cabbage Site

Pre-release Cabbage 2 for testing - part 5

I’ve uploaded new binaries for Windows, along with support for plugins. Please test them out and see if they work Ok.The best thing to do is create a new folder within your Cabbage64 dir and place them in there. This release should address the issues last brought up by users, and also adds the image crop identifier() so users can avail of filmstrip pngs. See the new example in Examples->Instructional. I’ll upload Mac binaries tomorrow.

Win64 (updated 17th May)
[OSX (Updated 18nd May)] (

One thing I’ve experienced is not being able to export VST files with the beta.

I made a new folder in my Cabbage64dir called “ver2” and put the beta files there. It opens and i’m able to work within Cabbage 2 without issue.

When I export, the vst files are not working. Ive tried Reaper and Mixbus, both have not worked for me.

Don’t know if you seen this issue on this pre release.


Thanks, this has been reported and I hope to fix it tomorrow. Watch this space :wink:

I’ve updated the OSX binaries. And I did a quick test here and was able to export without any issues. @smackaudio, I will check on Windows a little later, but I can’t recall having an issue with them on Windows, and I know some other users are also able to use them Ok. I’ll check it out and get back to you.

Thanks for the update Rory,

Ill give the OSX version a spin. But, i was unable to to export working vst’s from the Win64 beta.


I just tried again here and had no problems with either synths or effects. Are you sure you’ve added the correct path to Repear?

Yep, i’m positive on the plugin paths to reaper.

Same path as other plugins ive been working on with Cabbage.

Should i install the beta over the existing Cabbage64 dir instead of using a second directory?


I don’t think it will make any difference. It doesn’t matter where the new binaries go as long as Cabbage 1 is installed. I have mine in a folder on the desktop. Maybe try moving them. Does Cabbage actually create the dll files when you export?

yep they do create a dll file, but Reaper doesnt see it. Even after i have the path re-scanned.

Can i email you the exported files to see if it works on your system?


Are the .csd files int the same directory? With the same name? If so, can you zip one, along with the dll and send it on? It might be a little large for this list. Maybe you can dropbox or wetransfer it?

here is a simple gain vst done in the beta


Runs perfectly fine for me here. Does Repear even list the VST?


No it doesn’t, which is odd.

Can you try clearing and re-scanning the plugin cache in Reaper? It’s very odd. But there is most likely a simple explanation…I hope!


think I’ve solved the issue!

I installed the Visual C++ Redistributable 2015 from Microsoft. That seemed to fix my issue on my machine. I exported a vst with the beta, then opened reaper, and it worked!

So it appears to be a local issue with my machine.


That’s good to know .Thanks for posting the solution. It may help someone else in the future!

Hey Rory,

I tried exporting a csound file (including a provided example) as VST effect on a friend’s mac. No luck. Cabbage creates a .vst file, but it isn’t picked up by any daw. This was the same issue I encountered with the latest Cabbage 1 beta. Is there anything I am missing?

This is odd. It’s working fine for me whenever I try to export. I can’t think of anything that might be causing an issue? Cabbage 1 works fine?

Yup, I tried on Cabbage 1.1.0. It has several problems after being exported (such as media files not being loaded), but it gets picked up by the DAWs.

What version of OSX are you using?

p.s. media files should be picked up if there are in the correct location, which is inside the .vst bundle.