Cabbage Logo
Back to Cabbage Site

Problem Exporting VST and VST3


I’ve been trying to export my VST Plugin lately, cabbage always exported without problems both VST and VST3. I’ve tried today after a couple of changes in the plugin, but it gives me this error, exporting both VST and VST3:

How can I solve it?

I’m using Cabbage version 2.8.153

Thank you very much

What OS are you on? Looks like windows, but the dir structure looks more like Linux or Mac?

Hi @Gabriele_Manniello did you resolve this? @Oeyvind is seeing a similar issue. I updated the build system recently to use universal Csound, maybe this is the problem. Can you try this one instead:
It uses the old x86_64 build of Csound.

I just checked the build arch of the latest MacOS images. They are supposed to be universal builds but they are still showing as x86_64. I’m looking into it. It might be the reason we are seeing problems with the latest Mac betas.

Hi @rorywalsh, I’m using Mac, I’ve tried the new version but no results, still the same problem.

I’m on MacOS Ventura by the way.
I’m also not seeing the AU component export function, but maybe that is just because it was removed.

Thank you for the support!

And it’s an M1 Mac?

No, Intel

It seems to me that some of my platform tests are failing. This line here checks if we are running on a Mac, and if so, adds those menu commands:

This might also explain the strange error regarding the Cabbage dll. I will change that code so it uses basic ifdefs, that should resolve it. I’m teaching all, so please be patient. If I don’t get something for you to test today, it will be tomorrow at the latest.

@Gabriele_Manniello There is a new build under way. Can you try it once it’s cooked?


Thank You!