Cabbage Logo
Back to Cabbage Site

Running in DAW issue

Hey guys,

I’m having an issue when importing my cabbage in vst into my daw. The instrument works fine in cabbage but when I export as a pluggin synth and load into my DAW it is very slow and the sound is very distorted.
None of the sliders or knobs work.

I can get the pluggin to work (sometimes) by choosing “Use fixed size buffers” and changing other processing options in the pluggin options in the DAW.

What might be the issue? Could it be a CPU issue?

The DAW i’m using is FL studio.
This issue also happens with any of the example patches no matter how simple the instrument is.

Thanks!

I’ll download a demo of FL Studio now and try myself. What version of Cabbage are you version?

Thanks rory!

Cabbage is version 2.0.28a (64 bit)

There’s a newer version here for you to try out. I just tested here and I don’t see any issues with the GUI, although the audio didn’t sound great. I’m hoping that’s my lack of experience with FL Studio over a problem with Cabbage.

Thanks will try that now!

Alas, the issue still persists. Tried it with the example file just now and the audio is very distorted and any gui elements I add become very slow after a few moments.

If I can get another DAW i’ll try it in that.
Everything works fine in cabbage itself.

Thanks for the help!

Try Reaper? It usually always works best in Reaper. If problems still persist we’ll know it’s Cabbage at fault.

Seems to work fine in Reaper. Hmmm Must be an FL studio problem then. I think I’ll keep working with my instrument in cabbage for now and record from within cabbage. Having the instrument work in FL was mainly a bonus anyway.

Thanks for the help Rory!

I’ll see if I can find the cause of the problem, although I’m not really sure what the problem might be.

If you switch on “Use fixed size buffers” and other options in the wrapper settings in FL it seems to work better but still with distorted sound. Not sure what those settings really mean but I guess they have something to do with CPU use?

Thanks for that info. I’ll try it out.

I’m having similar trouble with all VSTs exported from Cabbage in FL Studio 12.4 on Windows 10 with Csound 6.10; the VST GUI is blank (just a black rectangle) and doesn’t seem to respond to MIDI input or otherwise generate or pass through sound. Hopefully I’m not reviving too old a thread. The standalone Cabbage program works completely fine as far as I can tell. I’d be happy to try building from source on my system and trying some debugging if that would be helpful; I’m not super-knowledgeable about C++/JUCE or the Windows platform but might know my way around well enough to be of some use.

I don’t see a “Used fixed size buffers” option in my version of FL Studio, but looking at the ASIO config it looks like the buffer size is fixed at 512 samples.

If we could get this to work I’d be overjoyed! Csound has some wildly powerful opcodes even compared to big expensive commercial synths, and I’ve written instruments in it I’m really fond of, so I’d be super sad to have to give them up in order to work with this nice sequencer. :stuck_out_tongue:

EDIT: Oh, almost forgot to mention, I’m using Cabbage (64-bit) v2.0.02. As a side note, I assume the exported VSTs are 64-bit as well?

There were some issues with FL Studio, but they have been addressed as far as I can see. I just tried exporting a few instrument just now and everything is fine, see below. Are you sure the .csd files are in the same folder as the dlls? (this is how Cabbage exports them by default. but some people try to organise things a little differently…)

Oh goodness, I’m so sorry, that was exactly the problem! I should’ve read the documentation more closely. :flushed: One thing I do note is that I get distortion and popping in a lot of Cabbage VSTs in FL Studio unless I set the sample rate to 48000hz and the buffer size to something relatively large like 4096 samples. It’s not really a problem, just seems sort of strange, since in the Cabbage standalone I can set the buffer size an order of magnitude smaller than that without issue. Anyway, thanks so much and sorry for my silly mistake!

No problem, glad to know that was the problem. As for the dropouts, I just noticed them too. How odd, I don’t see this behavior in any of the other hosts I’ve tested Cabbage on. I’ll see if I can find the cause…

Issue seems to still be present with Cabbage 2.1.00. I tried changing buffer sizes, audio drivers, sample rate, ksmps, the fixed-size buffer option, etc. I was able to make the amount of noise lower a little bit, but not ever completely go away. What was most interesting was that the noise persisted into exported files – it wasn’t just that it was having trouble keeping up, something’s off with how FL Studio is actually running the file.

LMMS had no such issues, and ran it just fine.

Versions 2.1.00 is relatively old at this point :wink: Can you try the latest version? I think version 2.1.03 was the one where @T0NIT0RMX and I finally got to a place where there were no longer any issues with Cabbage and FL. Can you let us know if problems persist. I’ve not been able to recreate any here in either Windows or OSX…

Yup, works fine now. Sorry for bumping an old thread without checking first.

No problem. I’m happy to know if working for you :sunglasses: