Cabbage Logo
Back to Cabbage Site

Tap Tempo Delay

Hey there,

Here’s a simple delay plugin that I made using Cabbage and Illustrator. It features a Mono to Stereo delay with the ability to sync to a host tempo, or provide a tap tempo. Feel free to use the components or concepts of the build as you wish. (1.6 MB)


Very nice. Putting the overlays on top of the VU meter works very nicely. I won’t get a chance to actually try it out until I get back to Ireland. I’m looking forward to having a go at it.

Impressive look!

Hey, thanks for the response! But could someone tell me if they can export this as a VST and use it on their DAW? I’m able to export fine, but when I load it on to my DAW, it doesn’t seem to function. It’s as if the DAW is bypassing the VST altogether. Am I missing something here?

I just tried it here on Linux, it works fine with Bitwig. Just as I’d expect. I’ve pretty crappy speakers from this laptop, but I could definitely here the effect working when I enable it. What DAW are you using?

So strange. I’m using Reaper, 64bit, Win 7.

Oh wait, it is working! I had Cabbage open the previous time I tried it. And I closed Cabbage and checked, didn’t work. I closed both and opened Reaper alone, seems to work. Thanks anyway…

Hi, this might go a little off-topic… I gave it a go and exported a VST effect. But putting it in my VST folder made Ableton crash on startup (as it scanned plugins). Removal remedies, and I repeated the process several times.
Trying to open Reaper and I get Python errors.

VST.rar (2.5 MB)
I exported a different script to VST and tested it, and that worked fine.

V1.1.07 Win7 64

@Rory Incidentally, I get this same Python error every time I load this version of the standalone player, although cabbage loads when I hit ok. I’ve tried with and without installing the Python opcodes bundled with cabbage.

Hey there,

I faced start up crash while Reaper was scanning plugins too. But this happened only once, every time a new instance of the plugin was introduced into the VST folder. Maybe something to looking into.

python27.dll was an error that I encountered too. But only when I was trying to make an installation package builder from a minimal csound bundle. That and another missing dll, libwinpthread-1.dll.

I got libwinpthread-1.dll from the main Csound installation, and I got python27.dll from another software altogether, and placed them both in the csound\bin directory. That seems to suppress the errors. But I don’t know why it needs python27.dll in the first place. Rory?

Remove py.dll from the Cabbage directory. Csound tries to load the python dlls when it starts up, if you don’t have them you get this error. See if that fixes the issue…

Removed py.dll
That’s cleared the error from the standalone player, but Ableton still crashes, and Reaper now crashes without displaying the Python error.

Do you get any error messages now when you try the plugin?

When I export Thrifleganger’s delay, yeah neither DAW would start up. But a fresh export of a different plugin works ok. No onscreen messages though.

Hey Jay, could you try exporting Examples > Instructional > SVGExample as VST and trying it on your DAW, to see if it’s a custom SVG issue?

Note that you should also place the .svg files into the same folder as the exported SVG example. Strange that you are both on Windows but are having very different experiences?

I’ll hopefully get a chance to test that out over the weekend.

hi, i’m windows too and i have the same problem. except it works on my system. but when i load it with another, Ableton crash. i test it on “vst host” and it crush too. but on “Cubase”, “one studio” and “FL studio”. it works perfectly. it seems “vst host”, “ableton” and “Reaper” have this issue…