Cabbage Logo
Back to Cabbage Site

Temporary workaround for comboboxes

How about this as a temporary workaround for refreshing comboboxes after a snapshot file has been loaded?

refreshingcomboboxes.txt (2.6 KB)

On another subject, I used Cabbage as a plugin and now I understand why texteditors are “layout”. :wink:

edit: I’ve found that for this workaround to work after you’ve just started Cabbage or after you “Reload Instrument”, your *.snaps combobox has to be placed after all the other comboboxes in the code.

I’ll try this out a little later. The first thing I test when I make a change to any of the combobox code is to place one in an instrument and launch it as a plugin. Then try to change the combobox value using one of the hosts native sliders. If it behaves as it should it’s good to go!

[edit] I just tried this and there doesn’t seem to be any ill effects. I’ll push it through the the dev branch now. Might be worth a few more tests all the same…

Do you mind telling me what software do you use for testing automation in Linux? I tried ardour, qtractor and carla. None of them work for me. Qtractor says:

Csound version 6.06 (double samples) Oct 10 2015
compiled Ok
Everything has been setup without an issue.
JUCE Assertion failure in juce_VST_Wrapper.cpp:320

Mostly I use Bitwig, but it’s not free. I’ll try ardour now and see what happens…

I’m getting no crash with Ardour. Which version are you using? I’m on 4.6?

BTW. Ardour 4.6 is really nice!

I am on 4.4. I’ll try to build 4.6 now.

Wait, maybe it’s because of my lack of understanding of VSTs. Should I see the Cabbage GUI updated when I use automation in a host? I can automate Ardour native controls, but I don’t see that reflected in the Cabbage GUI when I press play.

That’s correct. You should be seeing the Cabbage GUI update when you add automation. But remember to select the ‘Play’ mode for the automation. Otherwise it won’t update. Btw, I used the following guide to set up 4.6:

Unfortunately I can’t make it happen. Could you post your .so and .csd? Could I use that to test?

Ardour really keeps getting better and better. If I had money, I would totally donate to that project!

I just exported a one of the example effects. I used clip. Here’s how I set it up.

Thanks for that Rory. I was doing exactly the same, but instead of using an example I was using the default template used when you do “New Cabbage…->Effect”.

The gain rslider did not work with that code and I went mad looking for the cause of that. Finally, it’s because in that template the rslider doesn’t have its range attribute defined!

Do you know when you’ll have a new beta released? I’d like to try my oscillator bank with the newest changes introduced in the develop branch. I have Windows 32-bit in an old notebook and I could try OSX on Friday. BTW, fftdisplay is an excellent idea! I saw a glimpse of it when I cloned the repo yesterday.

You mean the changes you contributed yesterday? I can run off updated betas for OSX and Windows before the weekend. Once i have this FFT viewer in place I think I need to stop developing and concentrate on putting a new release out there! It’s a long time since I merged the dev branch into the master one!

I’ll update that template example now! Sorry about that!

Yeah, I need those changes. We’ll have one synth (for additive synthesis) and then rely on snapshots for teaching different subtopics.

I would be amazing if you could post updated betas before the weekend!

I think it’s a good a idea to have a new stable release. Develop is really cool now and all the people that can’t build by themselves is missing out that.

I’ve update the OSX installer so it now ships with the changes you proposed. You can grab it here:

The Windows installer I can build from home. I’ll let you know when that one is ready.

Cheers Rory! Thank you for that.

I’ll be able to test it in a couple of hours. Don’t worry about the Windows installer, I’ve managed to build Cabbage in Windows myself. I haven’t dealt with the installer files yet, but I tried doing those tasks manually(copying files, etc.) and it works. So, take your time and I’ll test it when you have it.

Here you go:

I’m impressed that you got Cabbage building on Windows. I know a few people who struggled with that in the past! Btw, I got 64 bit Csound building with MSYS2. It took about a half hour to get set up. Steven Yi from the sound list helped me. Compared to the usual hoops one has to jump through to get a full Windows build of Csound, this was very simple. But if you have everything building then maybe stick with what you got!

The OSX one worked fine. Couldn’t test the other, because it was an netbook with 32-bit Windows 7. But my Windows build worked there.

The problem is -and I’m deeply sorry I did not check this before asking you- that the development branch does not include the modifications that allowed us to save and restore Texteditors! I didn’t know how hosts and plugins interacted until recently, but I think the changes in the audio-unit branch are harmless in that regard. I use this to construct envelopes on the fly. It can be an interesting feature to have to be able to save strings.

It took me a day or so to configure MSYS! What I learned is that I love Linux even more than before. I’d also need 32-bit Windows installers because of this OLPC kind of program being developed in my country.


Darn it. I was sure those changes made it in? I must have forgotten to commit them. I can have a new OSC build on Monday if that’s Ok, with these updates. I just won’t be at my OSX machine until then. I can however produce Windows installers today with the changes in place.

I see the changes there in the dev branch of the code? Did I miss something?

I can’t explain what happened! After I posted yesterday, I checked and didn’t see those changes in github. And of course I posted because when I tried the installer in OSX and the snapshot files didn’t contain the texteditor’s contents.

Unfortunately I won’t get access to OSX before a couple of weeks to try. Here I can try in Windows 32-bit and Linux. But if you have access to OSX, maybe you could try to install the installer you produced and see if saving texteditors works there.