Cabbage Logo
Back to Cabbage Site

The old Run-fine-first-time dance

Hey Rory,

I’ve been trying to use Cabbage to test out my orchestra files along with some score variations. This particular Csound file is all in one, but I’ll be damned why it would run in Cabbage the first time, but immediately dies on the second attempt to run. Everything seems to run fine from the commandline with csound, but it would be nice to have an orchestra that doesn’t crash to build an interface (eventually).

I’ve upgraded by version of Csound to the latest release, and Cabbage says this about the version…

–Csound version 6.18 (double samples) Nov 6 2022

Huh, well, dang it… Now that I have added a very basic Cabbage window, it isn’t crashing… And yes, as a test, I tried commenting out the Cabbage stuff, and everything ran fine without trouble multiple times…

But when I actually deleted all of the Cabbage tags, it runs fine the first time, and crashes on the second…

If it might be of help, maybe we can get other people to test this and see if it crashes for them. Is this a platform issue? Being on a Mac, running an older system, my guess is it probably is…

Here’s the code without the Cabbage tag…

FM_Duo_01.csd (6.7 KB)


I love these ones :rofl: It could be a bug. To be honest, I’m not sure how many people ever use Cabbage as a vanilla Csound editor. But I’ll take a look. If it crashes on the second attempt it’s usually an issue with Csound not exiting cleanly. I’ll take a look and let you know.

That was an easy fix. Works fine for me now. Check out the Azure DevOps page for the latest beta.

I had been using Csound directly for this project, and it was a few days ago that I started to use Cabbage as a vanilla Csound editor. I figured that because the Cabbage “Csound project” creates the file without a Cabbage tag that it was the intent to run without a Cabbage tag. I know that it is very simple to add that tag, and my goal includes would require that add that tag…

Does adding the Cabbage tag do anything to make this bug go away? If the problem lies in Csound, I can see why running it from the command line wouldn’t show this bug. Does Cabbage start Csound once when it starts, and then just recall the same instance on each run? Is there a way to restart Csound from within Cabbage? I’ve noticed that after opening and closing a Csound project file, the running instance can getting kind of full with instances of those instruments still compiled and running.

Besides, I wonder if there are others who are doing what I’m doing. Testing out these Csound files before starting in with Cabbage. I’m trying a new workflow. I am trying to get the Csound files are close to complete before I start in with Cabbage. And this is what happened literally the first time that I tried to use Cabbage… I wonder how many others have done this only to be thrown off Cabbage because of this?

Thanks for your quick response!


It’s all fixed now, and should run fine. So it should work just as you expect to. If not, let me know and I’ll do my best to find the solution.

Thanks, Rory… Works fine now.