Cabbage Logo
Back to Cabbage Site

Trouble mapping a hardware midi controller on cabbage plugin parameters

im having trouble mapping any hardware midi controller (knob, fader etc) on any cabbage plugin parameter.
My DAW is Logic 10.4.4 and have tried using:

  • Different controllers
  • Exported AU from various examples and on my own plugins.
  • Tried different setting in the mapping parameters of Logic.

The controller maps, but does not respond when moving the hardware.
When moving the Cabbage plugin slider/knob then the hardware controller responds ok (on my bcr2000 & on Bluecats Patchworks).

Thanks much in advance!

Is this AU only? I’ll have to check when I get back to work in a week or so…


both VST and AU on a mac. I also load them through Bluecat’s patchwork and the behavior is the same.


Thanks. I’ll look into it. Apologies in advance for the delay in doing so. I’ll need to wait till I can get my hands on a MIDI controller…

No worries and many thanks!
You may try it and reproduce the issue without a midi controller. Bluecat’s Patchwork is a plugin (works with any DAW) that you can load VST/AU/VST3 plugins within it. It will allow you to load the plugin and map parameters on its knobs just like any midi controller (the trial will work just fine for this purpose). So, it will be like emulating a midi controller.
If it works there it will work with any DAW.
(btw im not affiliated with Bluecat or anything :slight_smile:

I’m stuck in a land without internet for the next few days (places like this still exist in Ireland!) so I won’t be able to download that plugin to test it out. But from what I read it simply hosts plugins? I can easily map DAW parameters to Cabbage parameters though. So I assume if I map MIDI to those parameters it will work fine too. Can you confirm that you can also do this, as shown in the screencast below?

Btw, this also works when I draw automation curves…

Yeap, that seems to work fine in Ableton. I was testing in Logic on a Mac.
When i go home in the afternoon i will test it in both and let you know
(in Logic when i moved the Cabbage plugin parameters it would move the midi controllers leds, but when moving the hardware controller’s knob it would not move the plugin knob)
Thanks much for the support and looking into it!

Let me know how you get on👍

I have a VM on my Mac which i use for development.
When i wrote the post, i had been testing in the VM with Logic 10.4.4
Today, i reboot the VM and tried to give it a clean start.
It worked ok in Ableton Live 10, and then using BC Patchwork on AL10 and then eventually after a couple of non working tries it worked in Logic 10.4.4 in the VM. So, on the VM works great today.

Then i decided to test it on the Mac host. On the host i had updated in Logic 10.4.5 and have AL10. I test it Ableton and works fine.
I tested within BC Patchwork in AL10 and works.
I test it in Logic and it does not! I load BCP in Logic and load the plugin, AU,VST, VST3 and does not work!
Even within the BCP plugin in Logic 10.4.5 did not work. (It works one way when i move the plugin knob, but not the other way around.)
I did a couple of restarts of the Mac and still the same.
I tested with a bunch of other 3rd party plugins and they map and work ok.
I don’t know what to say…

The question is, why must you use that plugin, to host a plugin, in a plugin host? I’d rather look at why it doesn’t work natively in logic than investigate a host plugin plugin. I’ll have access to a Mac again in a weeks time. I’ll check it out then. Thanks for looking into it for me :+1:

Im just using BCP to test because i thought if it loads any plugin and works independently of DAW but obviously is not the case.
One more detail, the BCP can be loaded as standalone.
I loaded in it Cabbage plugins and the only ones that worked were the VST, nor VST3 or AU worked.

did you get a chance to test Logic on this mapping issue?

I’m afraid not as I don’t have logic. But I plan to test with mainstage and garage band on Monday. I’ll let you know. And thanks for the reminder.

Hi, did you manage to test it on Garageband?

Apologies, I didn’t get around to it. My only access to a Mac is pretty limited over the summer months. I will have to visit it on Friday of this week, so I’ll put a reminder in my diary for it!

Great many thanks!

And wouldn’t you know it as soon as I made that commitment, my plans have changed. It looks like it will be Tuesday now before I get to my OSX machine again. Sincerest apologies for this. I’m not usually this long without a Mac!

Hi @mixalis, apologies in the delay getting back to you. I just tried it out here and it seems to work fine for me, although I don’t have Logic. But it works Ok in Mainstage. I made a short video demo, maybe you can take a look and let me know if you are able to do the same in Logic. Here’s the video link.

Hi, yes, it looks like it is working ok. I don’t know what is causing the issue on my machine. I will try to troubleshoot it then and see, it is strange though cause iam only having the issue with cabbage developed plugins.

Hi, i was finally able to test on my machine. In main stage it worked but then when tried it in Logic it maps on the smartcontrol. When i move the smartcontrol it moves the plugin’s controlled parameter. When i move the plugin control, it does not move the smartcontrol.
I then tested with other third party plugins and have no problem.
I am using the Cabbage Compressor plugin for this testing.