Cabbage Logo
Back to Cabbage Site

VST (and AU) not loading in multiple DAWs

I’m just finishing up a project with cabbage to create some music. Most instruments and effects are working, but I have had some problems with the VST’s not loading in any DAW(Reaper, Nuendo and Reaper).

My current plugin is a mix processor that works fine in Cabbage when I load some sample audio, but it won’t load into Reaper. It loads as an AU, but no audio passes through it.

A key difference in this plugin is that it loads PVOC-Ex files (.pvx) that I made with Csound’s PVANAL utility. Some of Csound’s PVS tools are using the .pvx files as noise masks for spectral processing (pvstencil).

On this plugin, I have exported it in these ways:
VST3 effect (ad hoc code signed) - no joy in Reaper
AU (ad hoc code signed) - It loads in Reaper, but no audio plays through it.
VST3 Instrument (ad hoc code signed) - This loaded in Reaper - but no sound through it.

note: I have copied the .pvx files into the same VST3 plugin folder.

I tried importing the code into a new Cabbage project and naming it differently, but no joy there either.

I also tried creating unsigned versions and that didn’t work either.

Any ideas?

Many thanks, Fergal

Macbook Pro M3(2023)
Sonoma 14.5 (23F79)
Cabbage Version 2.9.0
Csound Version 6.18.1

The first thing to do is update your build of Cabbage. You’ll find new builds here:

(There is a sticky on the main forum page about accessing them in case it’s not clear).

Then you will need to provide an absolute path to the PVOC files. To do this you’ll need to first find the path to the .csd file using

SPath chnget “CSD_PATH”

you can then construct the path to the PVOC files from this. Older versions of Cabbage changed the CWD to the .csd file but this messed up some hosts, so we are now forced to construct all paths manually.