Cabbage Logo
Back to Cabbage Site

VSTi validation problems

In the latest build 2.3.35 I seem to be having an issue loading exported VSTi (instruments) as far as my tests have shown

macOS Mojave
observed in Bidule and Renoise

I’ll take a look.

Working fine here, both in Bidule (see below) and Renoise…

What happens when you try scanning the plugin using PluginVal?

OK PluginVal reported this

pluginval v0.2.4 - JUCE v5.4.5
Started validating: /Users/boonier/Library/Audio/Plug-Ins/VST/PadSynth.vst
Random seed: 0x589d44b
Validation started: 19 Mar 2020 11:34:00am

Strictness level: 5
Starting test: pluginval / Scan for known types: /Users/boonier/Library/Audio/Plug-Ins/VST/PadSynth.vst...


0   pluginval                           0x000000010f1d9190 _ZN4juce11SystemStats17getStackBacktraceEv + 64
1   pluginval                           0x000000010f1594d6 _ZN12_GLOBAL__N_119getCrashLogContentsEv + 38
2   pluginval                           0x000000010f15946b _Z11getCrashLogv + 107
3   pluginval                           0x000000010f15e4e5 _ZN16ConsoleComponent22changeListenerCallbackEPN4juce17ChangeBroadcasterE + 101
4   pluginval                           0x000000010f2145d5 _ZN4juce17ChangeBroadcaster25ChangeBroadcasterCallback17handleAsyncUpdateEv + 69
5   pluginval                           0x000000010f218709 _ZN4juce12MessageQueue21runLoopSourceCallbackEPv + 201
6   CoreFoundation                      0x00007fff3dd33de3 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
7   CoreFoundation                      0x00007fff3dd33d89 __CFRunLoopDoSource0 + 108
8   CoreFoundation                      0x00007fff3dd1774b __CFRunLoopDoSources0 + 195
9   CoreFoundation                      0x00007fff3dd16d15 __CFRunLoopRun + 1189
10  CoreFoundation                      0x00007fff3dd1661e CFRunLoopRunSpecific + 455
11  HIToolbox                           0x00007fff3cf751ab RunCurrentEventLoopInMode + 292
12  HIToolbox                           0x00007fff3cf74ee5 ReceiveNextEventCommon + 603
13  HIToolbox                           0x00007fff3cf74c76 _BlockUntilNextEventMatchingListInModeWithFilter + 64
14  AppKit                              0x00007fff3b30d77d _DPSNextEvent + 1135
15  AppKit                              0x00007fff3b30c46b -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1361
16  AppKit                              0x00007fff3b306588 -[NSApplication run] + 699
17  pluginval                           0x000000010f212e90 _ZN4juce19JUCEApplicationBase4mainEv + 144
18  pluginval                           0x000000010f212de3 _ZN4juce19JUCEApplicationBase4mainEiPPKc + 83
19  libdyld.dylib                       0x00007fff69c913d5 start + 1

Binary Images:
0x10f152000 pluginval
0x7fff3dcdc000 CoreFoundation
0x7fff3cf6a000 HIToolbox
0x7fff3b2f3000 AppKit
0x7fff69c7b000 libdyld.dylib

for the PadSynth example

PLuginVal is great! Never heard of it before

I get the same with plugin val, but my plugins still load. Even still, there is something not quite right there. I’ll take a look.

PadSynth seems to be an issue for me. Did I mention that already?

Yeah, I tried PadSynth. It’s working for me in Bidule and Renoise, but something is causing a validation issue. I’ll take a look.

I just ran my locally built plugins through pluginval and they passed all tests. I’m going to trigger another build and see if that helps at all. I’ll let you know.

:grin: any of my Cabbage generated VST plugins are crashing PluginVal scan

I wonder is Mojave interfering? Can’t think why

But testing them individually using “Test file” yields no problems, they pass

Ok, so it’s getting stuck on the scanning but not the testing??

similarly when I scan new plugins say in Bidule, it freezes

Hi @boonier_due, can you let me know what version of Csound you are using?It looks like the issues are with the release builds. My debug builds are not causing any problems. Kind of makes it tricky to debug :roll_eyes:

I think I have it sorted. Just pushing a new fix now…

thanks @rorywalsh that seems to have solved the issue.

I do still get intermittent freezes (in the non 64 bit processing version?) however when opening a patch using the newly generated plugin, but I’ll try to get some logs when it does and send them over

I’m just doing some more work here on that aspect of the plugin creation and something seems to be a little hit and miss here too. I’ll keep you posted.