Cabbage Logo
Back to Cabbage Site

Wacom graphic tablet to adjust sliders, knobs etc

Hi Rory,
I tested a Wacom Cintiq 16 graphics tablet (as a second screen in windows 10) with some widgets. Basically it works, but the tip of the pen is misaligned with the mouse pointer. Cabbage appears to interpret the 1920x1080 resolution as another resolution.
Other thing: Sliders and knobs work, the button (on/off) doesn’t work.
Can you easily do something to improve the excellent cabbage?
Andrea Strappa

That’s a strange one. Do you have a compile at hand? It would be interesting to see how the basic JUCE plugin demo works. If that works Ok then we should be able to fix this. If you can’t build that demo let me know and I will do it here and send it to you :wink:

I installed Juce today. It’s new to me.
I tested AudioSynthesiserDemo.h and PluckedStringsDemo.h. They work well!.
Below is an example that presents the problem.

form caption("Quad test") size(400, 400), colour(58, 110, 182), pluginid("qud1") keyboard bounds(8, 298, 381, 95) checkbox bounds(110, 252, 149, 36), channel("buttonch"), , , colour:1(255, 0, 0, 255) label bounds(80, 40, 100,13), text("Play/Stop"), align(centre) hslider bounds( 8, 80, 300,50), channel("Degree"), range(0, 360, 0) ;, text("Degree") label bounds(108, 120, 100,13), text("Degree"), align(centre) hslider bounds( 8, 135, 300,50), channel("Dist"), range(1, 50, 1) ;, text("Distance") label bounds(108, 175, 100,13), text("Distance"), align(centre) hslider bounds( 8, 190, 300,50), channel("Rev"), range(0, 1, 0) ;, text("Reverb") label bounds(108, 230, 100,13), text("Reverb"), align(centre) -n -d -+rtmidi=NULL -M0 -m0d --midi-key-cps=4 --midi-velocity-amp=5 sr = 44100 ksmps = 32 nchnls = 4 0dbfs = 1

ga1 init 0
ga2 init 0
ga3 init 0
ga4 init 0

instr 1
ifrq = 1

kDeg chnget “Degree”
kDist chnget “Dist”
kRev chnget “Rev”

;krevsend = p4
;aout diskin2 “beats.wav”, 1, 0, 1
;idegree init 180

ktime metro ifrq
if ktime = 1 then
reinit reset
;idegree = idegree + 90
;if idegree >= 360 then
;idegree = 0

aout linseg .8,1/sr,0,1/ifrq-1/sr,0

;kdegree line 0, p3, 360 ;full circle
kdistance line 1, p3 , 1
a1, a2, a3, a4 locsig aout, kDeg, kDist, kRev
ar1, ar2, ar3, ar4 locsend

ga1 = ga1+ar1
ga2 = ga2+ar2
ga3 = ga3+ar3
ga4 = ga4+ar4
outq a1, a2, a3, a4

instr 99 ; reverb instrument
gkbt chnget “buttonch”

kOnTrig	    trigger	gkbt,0.5,0
kOffTrig	trigger	gkbt,0.5,1
if kOnTrig==1 then		;IF BUTTON IS TURNED ON...
 event	"i",1,0,3600 ;, gkRev
elseif kOffTrig==1 then		;IF BUTTON IS TURNED ON...

a1 reverb2 ga1, 3.5, .5
a2 reverb2 ga2, 3.5, .5
a3 reverb2 ga3, 3.5, .5
a4 reverb2 ga4, 3.5, .5
outq a1, a2, a3, a4

ga1 = 0
ga2 = 0
ga3 = 0
ga4 = 0


; sine wave.
f 1 0 16384 10 1

;i 1 0 8 0 ;with reverb
;i 1 10 8 0 ;no reverb
i99 0 7200

Are just using Cabbage on its own? I thought you were running Cabbage plugins in a host…ok, that’s interesting. Let me take a look.

Yes, I confirm, with Reaper I have the problem, with Cabbage it works. Sorry for my incompleteness of information.

Arghh, that’s even trickier!! :laughing:Let me have a think about it. But can you confirm that the demo JUCE plugins all load and work fine in Reaper with the Wacom tablet?

Just a moment, I make a little video…

Here I can’t send it:
“Sorry, the file you are trying to upload is not authorized”
Where can I send you a 6.5 Mb mp4?

I haven’t tried juce demo inside reaper, but with DemoRunner.exe. Where can I find a juce demo .dll?

I think you will need to build it yourself. I can create one for you later. Yeah, there is a limit on larger files to the forum. Can you post it somewhere? WeTranfser, dropbox, one drive, etc.?

WeTransfer is ok. Here I found a your mail:
Ok for WeTransfer?
Unfortunately I can’t devote myself to learning Juce these days.

I guess what we learned from this is that Cabbage is better software than Reaper :laughing: It is strange. How do other plugin load in Reaper? Also, do you have another host to test with?

I did the test with cubase 10. Here the plugins work!
I also tried Reaper’s own plugins. These in the graphic table work.
How about, will I have to report the problem to Reaper?

Do other 3rd party plugins work in reaper?

Halion Sonic Se (Steinberg) is OK.
Podolski (u-he) is OK.
Charlatan (BlauKraut Engineering) in OK.
I tried these.

Ok, so it does point to an issue with Cabbage, even if other hosts are Ok?

In Cubase 10 all three are fine.

Hi Rory,
I sent you two possibly useful videos.

  1. If I widen the reaper window that hosts the plugin GUI, the GUI widens and everything works.
  2. With a Philips monitor, instead of the Wacom tablet, replaced in the same port, it works.
    I have a concert tonight:
    Do you think I will be able to use the graphics tablet? It’s not easy. :slight_smile: )

I’m thinking that for live it would be a good thing to use a touchscreen as a second screen, in addition to the keyboard and pedals.

If you enable native UI in Reaper it should work, although you won’t get to see Cabbage widgets then? But for now it might be Ok?