Cabbage Logo
Back to Cabbage Site

Windows 11 Ableton Crash

Hey, I built a delay VST back in 2022 using Cabbage (CSD linked here) that probably wasn’t the best but I was pretty excited about and shared with people.

I recently upgraded to a new computer with Windows 11 and was having a hard time figuring out why vst wasn’t showing up in Ableton (still on Ableton 9.1.2, the same version on my old system).

I decided to re-download the latest version of Cabbage as of today and re-exported the vst2. I followed the old formula, including the .csd in the same folder and placing it in the correct directory.

Not only did it not show up, but actually caused a crash in Ableton with the following error message.
Disregard the name “PaxDelay2[BETA1.01]” I tried it with multiple different versions that all matched the corresponding .csd


I’m concerned that this might’ve happened on other systems too not just mine as I’ll get random downloads of this off my website sometimes and would hate to crash someone else’s DAW that has less understanding of how to potentially fix it.

Hi @yaboypax, I’m sorry to hear you’re having problems. Can you try exporting one of the examples and seeing if that loads? Also, when you say most recent version, you mean you grabbed a dev build from the Azure page yeah?

Unfortunately, exporting example plugins causes the same crash. It would have been nice if it was only my .csd that caused it.

Also I’m not on the latest pre-release beta, but the latest stable v2.9.0 release that’s on the home page. I’ll pull the latest dev build and see if it still happens.

I think you should have better luck with the latest dev build. :+1:

Still getting the crash as of the 2.9.157 build on January 24th. The latest builds don’t have Windows installers. You’re getting a ##[warning]Directory ‘D:\a\1\a’ is empty. Nothing will be added to build artifact ‘Installers’.

Also when the crash happens, the Ableton window basically halves in size with the same aspect ratio, then disappears. Idk if this helps but just thought I’d mention it.

Darn it, something must be up with the windows build. I’ll take a look. In the mean time , can you try this one?

Sure thing, thanks! Just to confirm, the crash is the same on that build as well ^^

don’t have a Windows 11 machine, but I will test this on my Win10 machine tomorrow and let you know. Can you give me the link to the installer for the plugin you offer for download so I can test that too? Thanks :+1:

Sure, the installers are on gumroad .

I justed tested this here on Win10 and Live 10 and I had no crashes, it installed and worked out of the box. I wonder if it might be an issue with the version of Csound you have installed? What I would do is rename the Csound directory in “Program Files” before you run the installer, then choose to include Csound. Then try it again. I assume “Program Files” is the only directory you have ever installed Csound in?

I just deleted csound from my Program Files directory and re-ran the installer with the option to include csound in the installation and I still get the same crash when I run Ableton. I’ve tested the installer before on Windows 10 and I never had a problem with it. It’s only with Windows 11 that the vst causes this crash.

Hmm, I guess it might be time to try Windows 11 :frowning:

It seems my PC is not compatible with Windows 11. I will try to find a PC at work with Windows 11 to do some testing on.:+1:

Thanks for keeping me in the loop :+1: